create IS File Permissions sections via sagcc 10.1

Hi guys,

I am trying to automate the creation of these File Permissions.
I can read them with a command like this:

./sagcc get configuration data MySpm MyISInstance IS-FILEPERMISSION_READ

this gives a result which looks like this:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

Now let’s say I want to add a path : /tmp/test so my xml becomes:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

I am unsure what the create command is for this. I have tried something like :

./sagcc create configuration data MySpm MyIsInstance IS-FILEPERMISSION_READ -i /tmp/demo/acl.xml

but this returns an error :

{"@id":“1554387746126”,“message”:“ConfigurationSerializer SPI could not be found for RuntimeComponentId “MyIsInstance” and ConfigurationTypeId “IS-FILEPERMISSION_READ” .”,“code”:“SPMCFCE0048”,“description”:“Platform Manager could not find a registered ConfigurationSerializer that can handle ConfigurationInstances with these properties.”,“action”:“Register a ConfigurationSerializer SPI implementation that can handle ConfigurationInstances with these properties.”}

Any idea what the create command should look like?

Hi Andrei,

Please use below command to update IS file permission:

./sagcc update configuration data localhost integrationServer-default IS-FILEPERMISSION_READ --input /home/test.xml --password manage

test.xml should be in below format:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

For more information you can refer below documentation:

https://:/cce/web/cc-help/index.html#page/cc-onlinehelp%2Fre-sagcc_create_configuration_data.html%23

You can verify whether the file is updated or not in below location:
/SoftwareAG/IntegrationServer/instances/default/packages/WmPublic/config/fileAccessControl.cnf

Thanks,
Ranjith

1 Like

thank you Ranjith,

the command worked fine using the password for the default Administrator local account. Now, how do I specify another user, assume I have a different local admin account and --user is not recognised as an option.

Hi Andrei,

I am not sure about the different user.

Can you please try with below command:

./sagcc update configuration data localhost integrationServer-default IS-FILEPERMISSION_READ --input /home/test.xml --username

Thanks,
Ranjith

1 Like

yup, that works, thank you again!