User Login / SOLARIS 8 / TAMINO 3114

SUN SOLARIS 5.8

Win 2000

$uname -a

SunOS anup28 5.8 Generic_108528-13 sun4u sparc SUNW,Sun-Fire


Dear Friends,

we installed TAMINO on SOLARIS 8 , applied all patches and started apache.

Now we wanted to start inoadmin.sh , but if we give our userid and password into logon page , we receive allways that these are " unknown userid or password " , why ?

http://anup28:9991/smh/login.htm


What can we do now ?


The processes are running :


sag 15700 1 0 May 29 ? 0:00 ./argevsrv -pid /usr/SAG/common/arg/var/argevsrv.lock
sag 15675 1 0 May 29 ? 0:00 ./argsrv -pid /usr/SAG/common/arg/var/argsrv.lock
sag 15693 1 0 May 29 ? 0:00 ./argmlsrv -pid /usr/SAG/common/arg/var/argmlsrv.lock
root 4680 1 0 14:10:55 ? 0:00 ./xtsdsdmn -name XTSDIR -port 12731 -directory INIDIR -dirparms file=/usr/SAG/c

nobody 15482 15477 0 May 29 ? 0:00 /usr/local/apache/bin/httpd -d /usr/local/apache -R /usr/local/apache/libexec
nobody 15480 15477 0 May 29 ? 0:00 /usr/local/apache/bin/httpd -d /usr/local/apache -R /usr/local/apache/libexec
root 15477 1 0 May 29 ? 0:00 /usr/local/apache/bin/httpd -d /usr/local/apache -R /usr/local/apache/libexec
nobody 15481 15477 0 May 29 ? 0:00 /usr/local/apache/bin/httpd -d /usr/local/apache -R /usr/local/apache/libexec
nobody 15479 15477 0 May 29 ? 0:00 /usr/local/apache/bin/httpd -d /usr/local/apache -R /usr/local/apache/libexec
nobody 15478 15477 0 May 29 ? 0:00 /usr/local/apache/bin/httpd -d /usr/local/apache -R /usr/local/apache/libexec


kind Regards,

Sedo
:confused:

Hi Sedo,

this may be a silly question, but are you trying to login as a user defined on the Solaris machine (should work) or as a user from the Windows 2000 machine (should not work)?

Once you are logged in to the SMH, you might find that you have problems accessing the Tamino part. If you receive the message “The user does not have enough rights to execute this command”, check that the user is defined in the registry.
Source sagenv.new, then execute:
regutil enumkeys "HKLMS\Software AG\System Management Hub\Products\Tamino\Users"

If the user you wish to use for administering Tamino is not listed, you can add it with the following command:
regutil create "HKLMS\Software AG\System Management Hub\Products\Tamino\Users<username>"

I hope this helps,
Trevor.

Dear Trever,

thank you for your answer. But your suggestions didn’t help me.

I’m trying to login as a user defined on the Solaris machine, but i receive allways same error message again

" Unknown userID or password "

( for your info )

I installed Fullpackage with INS311/4 .

thank you.

kind Regards,
Sedo

Hi Sedo,

is the anup28 machine on the Software AG intranet, or perhaps available to access over the internet?

I’m willing to spend a few minutes looking at the problem, if you would like.
You can e-mail the details to me at: Trevor.Ford @softwareag.com

Thanks,
Trevor.

Thank you very much ,Trevor. I send to your e-mail somethings.

regards,

Sedo :wink:

Hi Sedo,

I think that I may have made a tiny mistake!

Try the following:
login to the Solaris machine as “sag”
execute these commands:
. sagenv.new
regutil enumkeys “HKLMS\Software AG\System Management Hub\Products\System Management Hub\Users”

if the user “sag” is not listed, execute this command:
regutil create “HKLMS\Software AG\System Management Hub\Products\System Management Hub\Users\sag”

I think that this is the problem - having the key in “…\Products\Tamino\Users” probably doesn’t help if the SMH one is missing!

Let me know if it helps!

Cheers,
Trevor.

No, unfortunately it didn’t help me .

Regards,

Sedo

Hi Sedo,

I’m afraid that I only have one more idea on how to help…
I recommend that you contact Software AG Customer Support.
I hope that you will be able to find a solution to the problem with their help.

Sorry we didn’t find a solution,
Trevor.

Hi Trevor,

i have solved this problem.

I have installed apache server and Tamino again.

I must give some permissions ( a+rx) to httpd.conf file,because install - script could not find apache configuration file httpd.conf and i couldn’t change the directory name of apache / httpd.conf file during installation.

I have changed something in the httpd.conf file, too :

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------
LoadModule ino_module libexec/ApacheModuleIno.so
AddModule mod_ino.c
?
?
<Location /tamino>
SetHandler ino
Regfile /usr/SAG/common/rgs/REGFILE

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------

I renamed ApacheModulIno.v1.3.9.so to ApacheModuleIno.so and copied into …/libexec directory of apache :

/usr/SAG//ino/v3114/X_Port/ApacheModuleIno.v1.3.9.so


/usr/local/apache/libexec/ApacheModuleIno.so

__________________________________________________________________________________________________


The reason of problem is unknown .


Thank you for your help .

I’ll wait your e-mails about TAMINO

kind Regards,

Sedo
:stuck_out_tongue: :stuck_out_tongue: :wink: