Converting from 6.3 to 6.4

For years I have been running adabas 6.3 on my windows PC (windows 10).
After an automatically windows update I can’t start the DBA Workbench for adabas 6.3

Now I have installed ada642 communitu edition. And the adabas manager 8.2 is up and running.
In the list of databases I can not see my 3 existing databases, which is explained in the documentation, 6.3 is not supported.

How do I convert my existing 6.3 databases to 6.4? And get them into the DB-list in the new adabas manager?

It says that I can just start the 6.3 databases, then it will be converted.
But when I try to start adabas from the commandprompt it says that adazbuf.dll is missing.

Ivan Jensen

Try the ADACVT utility.

Please inform how do I run the ADACVT utility. Where do I find it? How do I start it?

Now I found the program.
But again, when I run this in the new installatio it says adazbuf.dll is missing.
When I run in the 6.3 installation with these paramaeters adacvt dbid=4 convert=640 it says ‘syntax error’

My installation directory is C:\SoftwareAG. I see adazbuf.dll in subdirectory AdabasClient.

ADACVT won’t work if the UCB needs to be reset. Try

adadbm dbid=### reset=ucb, ident=*

Hi Ralph.
Thanks for your guidance until now. But I have been strugling to get it work, without success.
Now I have decided to uninstall adbas 6.3 and 6.4 on my machine and start from the beginning.
Maybe I will need some assistance later :slight_smile:

I have now uninstalled my 6.3 version end reinstalled adabas 6.4
Adabas Manager is up and running, and also I have created new databases in 6.4.
But I can not convert/move the data from my 6.3 database to the new 6.4 databases.

When I excute the ADACVT util from the commandprompt I am using these paremeters:
It says: ‘invalid keyword’
What to do?

Try it without the comma.


Same result.
I have been searching for the documentation for ADACVT, but coudn’t find it.
Do you know where to look?

I found the documentation in Adabas Version 6.3 Release Notes.
And I have used a wrong parameter.
The last åarameter shpuld be CONVERT=V640

I forgot the ‘V’

Now everything is up and running
Thanks a lot for your guidance.

same problem