Connection problem!

Has anyone tried bringing up Tamino Schema Editor and then setting a DB URL…when I try to do that, it says that the connection failed…any ideas as to what I may be doing wrong?

Could someone please help me out with this?

Thank you in advance.



1. Is your database started?
2. Does the database exist?
3. Is the url correct http://localhost/tamino/dbname where dbname is name of your database.

Check these and see how you go



Thank you for your response.

The database was started and the database does exist. And the name of my database is Statutes, so the URL looked like this:


I still can’t connect to the db.

Any ideas as to what might be going wrong???

Thank you very much again!


What happens if you start a browser and issue the URL :


If this replies with 404 page not found the web server is not configured. If you get a Tamino response (an XML document) then the connection is ok and there is some other problem.

When I browse to that URL, I get a blank page. So I don’t get any errors but I don’t get any XML page either. Just a white blank page!

And the strange thing is I can’t view the source even!

Any ideas please???

Thank you again,

I would also check the webserver logs - it may provide some clues. For Apache I believe you should see a GET for /tamino/Statues and the number that comes after it is the response code.


Tamino is not supposed to answer to this


but when an X-Machine command like


is encountered, it has to answer with one of the following messages:

1) if the database is unknwon:
<ino:messagetext ino:code=“INOXHE8202”>Tamino database unknown.</ino:messagetext>

2) if the database is knwon but (most likely) not started:
<ino:messagetext ino:code=“INOXHE8201”>Can’t connect to server on host localhost at port 3219, TCP error code 10061.</ino:messagetext>

3) if the database is known and started:
<ino:messageline ino:subject=“Server”>is alive</ino:messageline>

[Sidenote: There is no function to give you a list of databases knwon to a webserver.]

Best regards, Andreas

Hi, I posted this in the Xmlstarterkit, installation forum as thee xact same problem is mentioned there.

Here it is:

I have just discovered an interesting fact. modiis.dll has a global filter reference in the registry at:

HKLM\System\CurrentControlSet\Services\W3Svc\Parameters\Filter DLLs

Remove the entry to modiis in this key, but leave the other part of the string there.

Remove the modiis.dll from inetpub\scripts from your ISAPI filter and add the modiis.dll from
\Program Files\Software AG\Tamino\Tamino\X-Port

Apply the changes, I suggest a reboot due to changing the registry.

Retry the connection from the schema editor.

See if it helps


I had the same problem with connecting to the DB from schema editor. My DB has started but I could not view it from the browser. It has the URL format of http://localhost:9003/tamino/dbname and the OS is W2K with IIS as web server.

I have created entries in registry to point to this db location (IIS mappings)

In my case, I have checked the registry that I had no previous settings under services for modiis.dll and I did add the tamino modiis.dll to my filter.

Any ideas?



Is your webserver running on port 9903? The way to access Tamino is via the webserver. By default this will be port 80, so the correct syntax will for the URL will be
If the webserver is really running on port 9903 then I suspect the modiis is not installed correctly or there is some problem their. I do suspect though that you shouldn’t be specifying port 9903 in the URL.

For me I always get the “The page cannot be found” message ! Please help me !