Can't connect to the database from the Schema Editor


I am using the starter kit under W2K server. Installation went fine, and I created a test database and started it. I have a IIS web server up and running on the localhost.

However, I can’t connect to the database from the Schema Editor, connection failed. I checked various things but without success.

Any help would be appreciated, thanks.

0. I use the path http://localhost/tamino/test1, test1 being the name of the newly created database. Database is started, system management hub works fine.

1. IIS was installed before installing the starter kit; as a matter of fact the /smh and /smh/cgi are there and seem to be well configured (tip from the install.txt file),

2. I checked the web server extensions, and it didn’t report any specific error. I can connect to the site with Frontpage without any problem,

3. I tried to login as admin, I suspected some permission problem on directories.


After reading more about the same problem reported in other discussions, I tried more things, but it still fails to connect. I guess the web server is not configured properly, but I can’t find what’s going wrong.

Here is what I tried, without success:

- changed the entry SAGXTSDhost to be (localhost) rather than theIP address assigned to the default web server,
- installed the ISAPI filter (modiis.dll, located in c:\inetpub\scripts) on the root server and the default web server, and loaded it,
- added admin and myself to the list of users, in the database security manager.

Any hint appreciated,



I have just discovered an interesting fact. modiis.dll has a global filter reference in the registry at:

HKLM\System\CurrentControlSet\Services\W3Svc\Parameters\Filter DLLs

Remove the entry to modiis in this key, but leave the other part of the string there.

Remove the modiis.dll from inetpub\scripts from your ISAPI filter and add the modiis.dll from
\Program Files\Software AG\Tamino\Tamino\X-Port

Apply the changes, I suggest a reboot due to changing the registry.

Retry the connection from the schema editor.




Thanks for the hint. Unfortunately, it doesn’t work.

Everything works fine with Apache though, on the same machine. I’ll try to reinstall everything from scratch on another server.


I am also facing the same problem,if you find any soln please let me know my id is

I’m having the same problem as JM and SWAP even after trying all the above (modiis in root and web servers, regedit, stop/start iis, reboot, reinstall).

Seems like an ISAPI filter, port contention or access permissioning thing.

Is anyone out there using Tamino with IIS4 and NT6a who couldn’t connect to a database? If you had the same problem, how did you overcome it?


I once had this problem when Tamino was used from another website than the default one (in IIS) and I solved it by adding a virtual directory Scripts (pointing to c:\inetpub\scripts) in the none default website.

Thanks for your suggestion GJ.

Although I am using Tamino from my default site I followed your lead and created a scripts virtual directory pointing to c:\inetpub\scripts, then stopped/started iis.

Still no success. I tried several combinations of URL in the schema editor such as http://localhost/tamino/mydb, http://localhost:3204/tamino/mydb, http://{mydomain}/tamino/mydb but none get passed the ‘Connection to Tamino from URL “…” failed’ error.


Poor us ! :frowning:
I’m facing this problem too, and I did try so many times following any recomments. But still unsuccessful ! Please help us slove this problem as soon as possible !
Thanks ! Best regards.


please see this topic.