Database Active but Cannot Connect via URL

I’m using Tamino v3.1.2

Windows 2000
IE 5

Help: According to the Tamino Manager I was able to create a new DB and the Manager Shows its active. However when I get Server Info and try the URL for the Database its saying the DB is not active with the error listed below:

Database http://localhost/tamino/welcome3_1_1_4
Status not active
Info Command “ping” returned:
“8400 - INOXJE8400 HTTP Error 404 Not Found”

Can anyone help me with this error? One thing I noticed the URL its using is incorrect…however when I change the URL, there is no difference.
nullnull"8400 - INOXJE8400 HTTP Error 404 Not Found" :confused: :confused:

Hi,

it looks like you are using the “Welcome to Tamino” webpages…

Can you ping Tamino directly through a browser?
Use a url like:
http://localhost/tamino/test?_diagnose=Ping

(Replace “test” with your DB name.)
If there is still an error, and the System Management Hub shows the database is running, check if there is an “inosrv.exe” process running [with the TaskManager].
If there is an inosrv.exe, check that the webserver is correctly configured for accessing Tamino. (There is a good chance of this, since the Welcome to Tamino is running.)
If still no joy, perhaps checking the versions of the webserver and browser is the next approach…

I hope this helps,
Trevor.

[This message was edited by Trevor Ford on 30 May 2002 at 16:44.]

I’ve tried several URLs that I think that the DB should be on and none seem to work…is there something I’m missing.
Can I find the URL somewhere in the DB Properties on the Tamino Manager?

Hi,

the URL is always in this format:
http://<webserver hostname>/tamino/

If your webserver is on localhost, and your DB is called test, this would mean the URL is:
http://localhost/tamino/test

What follows this part of the URL varies, depending upon exactly what you would like to do. To execute a query on the “ino:collection” Collection, you could do this:
http://localhost/tamino/test/ino:collection?_xql=/xs:schema
(This will retrieve all the schema definitions.)

Trevor.

My welcome Page is at the following URL:
http://localhost/tamino-v3.1.1.4/welcome
But the DB is at: http://localhost/tamino/welcome3_1_1_4

How is this possible? I’ve started the welcome3_1_1_4 DB but can’t access it via URL.

Should I create an additional Alias on Apache to point to /tamion/?

Hello again!

There are two different URLs in question here: one is the URL of the “Welcome to Tamino” webpages, the other the URL of the Tamino database.

When you start “Welcome to Tamino” via the Start menu, a URL something like this is used:
http://localhost/tamino-v3.1.1.1/welcome/index.html?database=http://localhost/tamino/welcome3_1_1_1

The http://localhost/tamino-v3.1.1.1/welcome/index.html is the address for the Welcome to Tamino pages. There is an alias defined for “tamino-v3.1.1.1” (or 3.1.1.4 in your case).
The second part - database=http://localhost/tamino/welcome3_1_1_1 - is the address of the Tamino database that the Welcome to Tamino application will use.
This can be changed on the “Server Info” page as you already noticed.

In your Apache httpd.conf file there should be a section like this:
#Software-AG–Tamino----
LoadModule ino_module modules/ApacheModuleIno.dll

<Location /tamino>
SetHandler ino

# --------------------------------------------- # End Tamino version

(I would be surprised if this is missing, as the Welcome to Tamino aliases have been defined.)
This effectively creates the “tamino” alias. (Requests to /tamino will be sent to the Tamino handler.)

I would recommend that you try directly addressing the Tamino database you have created, using the URL structure we have outlined in the last couple of postings. If there is a problem accessing the database, it will be easier to figure out if we are accessing it directly.

Cheers,
Trevor.



After browsing the following url
http://localhost/tamino/Telephone?_diagnose=Ping
all we got is “The page cannot be found” message !
:confused:
Please help ! :frowning:
Thanks !

Hi there.

We would need some more information before we can give a useful answer!

Which version(s) of Tamino have you installed, with which webserver(s), on which OS?

Easy things to check:
* are the Software AG services running?
* is the webserver configured for Tamino?
* is the webserver running?
* is the database running?

Cheers,
Trevor.

I’m using Tamino version 2.3.1.4 under Windows2000 environment and IIS

* the webserver is AUTOMATICLY configured for Tamino (I had ISS before install Tamino)
* the webserver running
* the database running

So what 's wrong !
Please.
Thanks.
Regards.

Hi there.

If you’re sure that the ISAPI filter is correctly configured and it’s active, you could next look into the IIS logs.

Please also see this topic for an interesting point on ISAPI filters.

The IIS log files can be found in this directory:
  C:\WINNT\system32\LogFiles\W3SVC1

The log messages are configurable, but you should see something like this:
  02:04:44 - W3SVC1 USATFO 127.0.0.1 80 GET /Scripts/modiis.dll _xql=Property[@ino:id<12] 200 0 8239 396 551 HTTP/1.1 localhost Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.0;+Q312461;+.NET+CLR+1.0.3705) -

The important things to learn from this message are that “GET /Scripts/modiis.dll” worked and the HTTP result of the query is “200”.

Cheers,
Trevor.

Dir sir !
What I got from my log file is
“04:17:16 127.0.0.1 GET /Scripts/modiis.dll/tamino/MyDB 404”
:confused:
any comment ?
Regards.

I got this message in the Event viewer of Win2000

For compatibility with previous versions of IIS, the filter ‘D:\Program Files\Software AG\System Management Hub\bin\argiisfl.dll’ was loaded as a global filter from the registry. To control the filter with the Internet Service Manager, remove the filter from the registry and add it as a global filter with Internet Service Manager. Filters in the registry are stored at “HKLM\System\CurrentControlSet\Services\W3Svc\Parameters\Filter DLLs”.
For additional information specific to this message please visit the Microsoft Online Support site located at:
http://www.microsoft.com/contentredirect.asp.
__
:confused: how’s thing ?

Hmmmmm. It looks as if the ISAPI filter isn’t correctly installed.
There is defintely a difference between the log file entries - the working one does this:
   GET /Scripts/modiis.dll
But the not working one does this:
   GET /Scripts/modiis.dll/tamino/MyDB

HTTP return code 404 is “not found”, which seems to support the idea that the filter isn’t working correctly.

Perhaps you should remove and re-install the ISAPI filter from IIS.
Bill Leeney provided me with a good document on how to configure the IIS filter, which is attached to this posting.

Cheers,
Trevor.
Tamino_Filter_installation.doc (77 KB)

Oh great Sir,
It’s work well now !
Thanks you very much indeed!
Best regards.

I’m sorry for my mistyping, Once again thanks any ways.
Best regards.

You’re welcome (though I think the thanks should really go to Bill!)

Glad we could help,
Trevor.

Hi, Trevor
I am using Tamino on WinXP (professional) with the IIS5.1 server, installed on the same laptop.

I am facing the same problem as the “DATABASE ACTIVE BUT CANNOT CONNECT VIA URL” group. The only thing is that i tried the “Tamino Filter Installation. doc” that you had provided, after which i can ping my database which gives me the following msg (i’l post part of it):
"<ino:messageline ino subject=“Server”> is alive</ino:messageline>

But still i cannot connect to the database via tamino explorer or schema editor.
Q 1: Will this configuration work if i am not online (connected to WWW).
Q 2: Is the database can be pinged why can’t it be accessed (even on the browser) i.e.
using http://localhost/tamino/<db_name>.
Q3: I also cannot access the Welcome to tamino page via the browser i.e.
http://localhost/tamino-v3.1.1.4/welcome/index.html?database=http://localhost/tamino/welcome3_1_1_4

I’d appreciate some help on this matter.
Thanks in advance
Ahmad