Configuring the taskclient properties on WmTaskClient Package

Hi team,

We are configuring the following properties in the taskclient.properties file stored inside WmTaskClient/config/ folder.

taskclientretries=0
taskclientusejms=false
taskclientimpersonateacl=
taskclientuser=Administrator
taskclienttimeout=60000
taskclienturl=http://MWS_HOST:8585
taskclientretrydelay=1000

I would like to know if we can set the password as well here itself, with additional property like below

taskclientpassword=*******

If yes, then please confirm the exact key name.

I tried searching for the same in documentation but couldn’t find one.

Appreciate your help.

Hi Firoz,

ideally this is configured once by using IS Admin UI and then via -> Packages -> Management and then open the Homepage of the WmTaskClient package (the "House"-Icon).

Looks like the password is then stored somewhere else but not in the config file.

Regards,
Holger

Hi Holger,

Thanks for your reply.

I did add the additional property like
taskclientpassword=*******
in the taskclient.properties and looks like it worked.
Will be deploying to higher enviornments and see if that works fine.

Hi Firoz,

I prefer the way of configuring via the WebUI and not storing it in the cnf-file as it is most likely not crypted then.

Due to security constraints we are usually not allowed to store passwords in plain text in the filesystem.
Very rare exception will be tolerated when there is no other possibility, but we are encouraged to try to check for a solution how the password can be stored in a crypted manner.

Can you explain why you want to have this stored in the config file and deploy it to higher environments?

All packages starting with “Wm” and “Wx” should be skipped from deployments, while only there config files might be different between environments. Once setup correctly, most likely there will be no need for further modifications.
The only config files which might need to change are those from WmPublic, when there are changes for fileAccessControl and OSCommands.

Regards,
Holger

Holger,

I totally agree with your points and the way I mentioned above doesn’t work. I thought it was working after deploying this way in lower environment where the default password of Administrator was used.but when I deployed to higher environment where the password is different, it wasn’t working.

Problem statement:
The problem is we are doing a Bamboo deployment of Integration server and once deployed the server should not be touched. So there is no option of setting the password in WmTaskClient after server comes up.

Resolution:
Bamboo is configured to use Command Central to deploy the IS, I worked on exploring an option of configuring taskClient package as part of CC deployment.
Updated the template.yml to configure the taskclient package with Administrator credentials fetched from Bamboo server during deployment. This way it gets configured in WmTaskClient but doesn’t get stored anywhere.
Solved the issue.

Appreciate your response and update.