com.exasol.jdbc.EXADriver cannot be cast to javax.sql.DataSource

I recently encountered the above error when trying to create a JDBC Adapter Connection to an Exasol dB.


  1. Install the Exasol drivers into the <IS_installation_directory>/IntegrationServer/lib/jars/custom. Restart IS.
  2. Configured a new JDBC Adapter Connection.
  3. The original datasource class supplied in the EXASolution User Manual ‘com.exasol.jdbc.EXADriver’ was replaced with ‘com.exasol.jdbc.EXAConnectionPoolDataSource’.

Created a JDBC select Adapter service to test - Executed successfully.

Hope this helps anyone out there trying to integrate wM9.8 with an Exasol dB using JDBC adapters.

[JDBC Adapter version 9.0 Fix 8.] (3.55 KB)


Hi Paul,

thanks for the post as it will be helpful to others.

When looking at the JDBC Adapter Users Guide it is stated clearly that the JDBC Adapter is using DataSource classes in comparison to WmDB package which is using Driver classes.

As far as I know this is the case for all JDBC Adapter versions (6.5, 9.0 and 9.10) and all current wM versions.

Additional info:
As per the JDBC Adapter Users Guide, best practise for placing the drivers is under <IS_installation_directory>/IntegrationServer/packages/WmJDBCAdapter/code/jars as long as the driver itself does not have a native library part.


Hi guys,

I tried both approaches mentioned above but I still get the error mentioned in this Thread:

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource Adapters:test_Exasol.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
com.exasol.jdbc.EXADriver cannot be cast to javax.sql.DataSource

@Paul: what is the Exasol JDBC driver you used?


My exajdbc.jar file is in both folders mentioned in this thread.

it works now, my mistake .

thanks for posting this Paul - very useful