JDBC Adapter error

com.wm.app.b2b.server.ServiceException: [ART.117.4002] Adapter Runtime (Adapter Service): Unable to invoke adapter service SelectRailCarsToProcess.
[ART.114.505] Error while invoking adapter service com.wm.adapter.wmjdbc.services.CustomSQL.
com.wm.adapter.wmjdbc.connection.JDBCConnection

Any thoughts please

I get the following error while configuring JDBC Adapter:
The JDBC DataSource class “com.microsoft.jdbcx.sqlserver.SQLServerDataSource” cannot be located.
com.microsoft.jdbcx.sqlserver.SQLServerDataSource
I am using com.microsoft.jdbcx.sqlserver.SQLServerDataSource
any help?

Hi Rightman,
We get this error while configuring the database connection. I assume u are using SQL Server. Check whether U have palced the required jar file under Integrationserver/lib. To know which type of Jar file to be used, check the help documentation on JDBC adapter window

Hi v-rock,
thanks for the reply.

I have read the help docs. But i am not sure where to find jar files for SQL 2000. i have added sqljdbc & sqljdbc4 to IntegrationServer\lib. but it threw the same error. i even address those two jars to IntegrationServer\lib\jars too. but not working.

ur help is appreciated. let me know where to find those jar files.

-rightman

for SQL server 2000, you need three jars:
mssqlserver.jar
msutil.jar
msbase.jar

search jdbc driver on microsoft website, you should get it.

thanks tongwang,

it worked. appreciated the response.

OK… There is a way to over come this.IS there any other Connection of same type which is in same configuration. If so then Simple copy that and change the parameter as per your requirements. Frankly to say even we enter the correct data source name and placed the jar files mentioned location, I too don’t know why can’t webmethods active the db connection. we used to have this problem,out of a gloom it got activated.