The below error is encountered while trying to fetch the control number from EDIControlNumber table. java.sql.SQLIntegrityConstraintViolationException: [wm-cjdbc40-0034][Oracle JDBC Driver][Oracle]ORA-01400: cannot insert NULL into (“WMTN”.“EDICONTROLNUMBER”.“SENDERID”)

The SenderID, ReceiverID etc are being passed in the input to the service fetching the control Number.
Also, the Partner IDs are set-up for Control Number generation on MWS.

Can any one please help identify the cause for this issue.

Thanks & Regards,

Which service are you running and what are you trying to do with control numbers from UI or custom service thru?


The service executed is “wm.b2b.editn.batch:getControlNumber” to which the required inputs - TNsenderID, TNreceiverID, standard, type, update, prodMode and version - are being passed. The control number generated is used as the ICN# in the oubound EDI document generated. Please let me know if there is any other I can provide.


Instead of via this service why don’t you configure in teh WmEDI homepage Manage Control Numbers section and have it configured desired?

Also the error indicates some constraint violating in the table may be dups with the sender/receiver combination…Did you check the table entries?

The control number generation is configured in MWS as the feature in wM EDI module 8.0 is deprecated. The service is used to fetch the control number from the wmTN data base (EDICONTROLNUMBER table). Also, one thing as you mentioned, I noticed today is there were duplicate entries present for the given Sender/Receiver combination. However, was not sure if that could be cause for this issue. Will try deleting the duplicate set-ups tomorrow and testing the process again.

Thank you rmg.


Yes you are right,even its deprecated via EDI home page you can still make it enable and edit it or use MWS itself to get more used…

Yes please check the dup entries and see how testing goes:

Please contact SAG tech support also if some fix available or make them aware of this issue:


Hi Hariharan_m *

I am facing same problem. Did you solve your problem? if yes, what was the solution?

anybody input in this is appreciated.


What was your exact problem with the Control Numbers generating from the TN DB or dup control numbers issue?

Also what is your IS/TN and EDI Module versions facing the issue?


Version 8.2 but MWS is not enabled and I used wM EDI module 8.0 to add those control numbers.

I am not sure what is the problem but i am using service wm.b2b.editn.batch:getControlNumber and it through that error.

New update:

The service is working fine if I set parameter “update” to “false” which will not increment the control number in the table.

This led me to a conclusion that the problem is with the update process.

Yes it make sense to adjust the field setting and glad to hear it resolved and not a bug :smiley:


The problem has not been solved yet… because the parameter should be true to increase the control number each time i send a documents.

waiting for any suggestion.

Hi Salam,

I also faced the same issue in WM9.0 and was able to fix by adding the configuration parameter EDIAllowCustomControlNumberSequences = strictCompatibility in the file properties.cnf. This file is located under WMEDI\Config folder. You may have to re-load the package after changing the property. Hope it will help you if your issue is still exists. :slight_smile:


Yes this should be the work around in 8.x and 9.x EDI module configuration and you can do this via MWS screens.

In 8.x it is set as “EDIAllowCustomControlNumberSequences=true”



The issue has been addressed in following KB article:

The following error occurs when running the IngEdiUtilities.edi:addICEnvelope Service in the WmEDI package:

“java.sql.SQLIntegrityConstraintViolationException: [SoftwareAG][Oracle JDBC Driver][Oracle]ORA-01400: cannot insert NULL into (“WMTN”.“EDICONTROLNUMBER”.“SENDERID”)”

What could be causing this error, and how can it be resolved?
Follow the below steps to resolve this error:

  1. Copy the sample-properties.cnf file from the
    <IS_directory>\packages\WmEDI\config directory
    to properties.cnf file in the same directory.

  2. Edit the copied
    <IS_directory>\packages\WmEDI\config\properties.cnf file, and add/modify this parameter as follows:

EDIAllowCustomControlNumberSequences = strictCompatibility

  1. Re-load the WmEDI package.


Thanks for updating this old thread!!