Invalid EDIINT message, ignored.

We currently have an 8.2 version running and have stood up a 9.7 version as part of our upgrade. All of our packages have been migrated along with the configurations, etc. In 9.7 we are able to send EDI via EDIINT and receive MDNs back with no problems. However, when a partner tries to send back a 997, or any other transaction, all that we see in the TN activity log is the message “Invalid EDIINT message, ignored.” No EDIINT message is created, just that error.

We need to get this resolved as soon as possible since we have lined up business resources for testing. Any guidance is appreciated.

Can you provide the content of that AS2 message?
Does it look like a valid AS2 message?
you can compare it with the other message that you received (MDN)

I can see this type of error in flow : wm.EDIINT:receive, and it occurs if the protocol is other than ftp, http, smtp.
Please check the protocol.

Hi ID,

We too did upgrade from 7.1.2 to 9.7, and see EDIINT messages being ignored. Can you please let me know if you did manage to find a resolution?

Thanks,
Pramod

Pramod,

I would say please open a ticket with SAG support as it sounds its not normal behaviour with the EDIINT module and they can assist you faster resolution!

HTH,
RMG

We had to set the property wm.EDIINT.receiverURLs=/invoke/wm.EDIINT/receive in MWS. Go to Applications/Administration/Integration/B2B Settings and set that add the setting if it is not there or change it to the service that you are invoking for EDIINT receive. The property needs to go in the EDIINT Module Configuration Properties.

ID

1 Like

Hi RMG/ID,

Thanks for your reply. Yes, appending service’s FQN to “wm.EDIINT.receiverURLs” property in IS_HOME/packages/WmEDIINT/config/properties.cnf did the trick.

wm.EDIINT.receiverURLs=/invoke/wm.EDIINT/receive,/invoke/./

Apparently this property was introduced with EDIINT Module 8.2.2 via EDI_8.2.1_WmEDIINT_Fix1, below description is from the readme:

[i]

EEO-2849
In webMethods Module 8.2 SP1 for EDIINT, the receive
functionality does not work as expected.

In webMethods Module for EDIINT,the receive functionality
does not work as expected when the user changes, clones, or
uses a remote alias for the wm.EDIINT:receive service.

This issue is resolved. When the user uses a URL other than
wm.EDIINT:receive, a new property, wm.EDIINT.receiverURLs,
must be configured. The new URL(s) must be appended to the value of this property.

New property reference:
wm.EDIINT.receiverURLs A comma-separated list of URLs.
The default is /invoke/wm.EDIINT/receive.
Note: The new URLs must be appended to the default URL,
for example,
wm.EDIINT.receiverURLs=/invoke/wm.EDIINT/receive,
/invoke/EDIINT_AS2/clone_Service

[/i]

Cheers,
Pramod

Yes that is the way to go…and thanks for the update and results :smiley:

And note you can update the config file via MWS EDI screens as well.

HTH,
RMG