Broker Server could not be started on Windows Server


After last Windows updates (MS Windows Server 2003 R2), I found out that following error messages in server log:

Unable to start JMS connection alias “PE_NONTRANSACTIONAL_ALIAS”: [ISS.0134.9064] Error creating connection: [BRM.10.4011] JMS: Unable to connect to Broker at “host:port”: Connection refused: connect

According setting in Admin Console on Integration Server, wm.prt.status:JMSControlTrigger is also not connected.

Afterwards I found out that after each windows server restart the webMethods Broker Server didn’t automatically started. And manual start fails with error in Event Viewer:

Error: The Server cannot initialize config session with URL “qs://D:\webMethods7\Broker\data\awbrokers71\default\BrokerConfig.qs”. Error code 1102: QS (-14) CORRUPT(QS-14) line:5339. [EXITING]

Can someone please tell me what could be the reasons?

We faced same issue in 7.1.3 quite long back because of abnormal restart while processing the documents by broker. It happened to be store is corrupted(not sure why it got corrupted) but we did replaced store file from QA

If do this, You will loose documents pending for processing in broker

1 Like

YES…This behaviour will be critial in production env’s as you may loose pending queued documents…Please be more Caution and take SAG tech support help just in case to avoid any larget impact and root cause analysis.


1 Like

Many thanks for your fast replies. Good news, that this has been occured on UAT environment, and lossing queued documents is not critical for me.

Sai, I’m sorry for my misunderstood, but what did you mean under “QA” and how you was able to restore store files? And about which store data you did mentioned in your reply? Is this BrokerConfig.qs.stor or BrokerData.qs.stor located in folder for Broker Server and Monitor?

Thank you,

I have similar problem, Sai, could you please clarify hat did you mean under “QA”?

He refers to copy the store file from other environments say test or pre-prod. What is the issue you are facing? Can you share the error logs?

Hi, tried copy from working env… The same error.


Fri Mar 27 14:01:31 2015, line:240, msg:NO_DISK(QS-15) operation:read #rc:510 #size:512 line:240
Fri Mar 27 14:01:31 2015, line:399, msg:1100: QS (-15) NO_DISK(QS-15) operation:read #rc:510 #size:512 line:240 line:209

1427461291 i 1314
1427461291 a 1229 {qs://D:\webMethods7\Broker\data\awbrokers71\default\BrokerConfig.qs} {1100: QS (-15) NO_DISK(QS-15) operation:read #rc:510 #size:512 line:240 line:209}

I could not find any information from logs except “NO_DISK”

Share the details logs please? Either from error logs/server logs/broker logs

Solved by re-installing and configuring new broker server.