Attempting to run bash script application via ApplinX

Product/components used and version/fix level are you on:


Detailed explanation of the problem:

Can ApplinX create web interface for bash script as it does for Natural but without Natural session ?

  1. Tried using TN 3270 from the Main Frame connection type to connect via SSH port but this option does not allow to set the Linux user to login into the shell preconfigured for the bash script.

  2. Tried Natural-IO protocol with NWO but the latter still invokes Natural.
    After replacing natural command in with the script bash name the script is executed but something keeps sending Enter to the backend prompting this application script to run forever, while ApplinX connection to the backend fails.

Is it any way to use web interface via ApplinX to execute the bash script application as it is executed in the terminal ?

Error messages / full error message screenshot / log fileL

The connection to the host fails while Enter is continuously sent to the script application running on the background

Is your question related to the free trial, or to a production (customer) instance?

licensed instance

Have you installed all the latest fixes for the products and systems you are using?

Natural 9.1.4

We’ve simplified the invoked script by eliminating the loop and read statements, leaving only the echo command that writes into standard output. However, the output continues to be written into the nwosrvd log.

Could you please confirm whether nwo is exclusively compatible with Natural, and as a result, ApplinX is unable to create a web interface for the Linux script?

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.