argbatch (backup database)

Hello!

I just want to backup my tamino db using the command like software "argbatch.exe"

Unfortunately using the following command:

argbatch backup database database=mydb

, … I got the following error:

==============================================
—Ecs error: 0 (l=0) goodness=0.
------Ecs error: 0 (l=0) goodness=0.
------Ecs error: 0 (l=0) goodness=0.—
==============================================

Also the “window error message box” displayed the message that the instruction from address “0x77cb7ee” is getting the address “0x6f672029”. Memory cannot be “written”.

What should I do to make “argbatch” to work? :frowning:

best regards,
Dariusz Baumann

I have also tried in the following commands:

1. argbatch set environment "help"
2. argbatch show environment
3. argbatch show commands product=“Operating System” user=dbc password=defghijk
4. argbatch show commands operation=show
5. argbatch show hwinfo
6. argbatch /?
7. argbatch /help
8. argbatch

Unfortunately, for ALL the commands I got error message like this:
=========================================
—Ecs error: 0 (l=0) goodness=0.—
=========================================

I also tested this commands on the other computers, and got the same error.

My software is:
1. Tamino 3.1.1
2. Windows 2000 pro

Any help will be very appreciated.

In advance, thanks a lot!

best regards,
Dariusz Baumann

Hi Dariusz,
This behaviour was first reported with Tamino 3.1.1.4 and was fixed in Tamino 3.1.2. If you contact your local Software AG representative you should be able to get a version of the fix for Tamino 3.1.1.

HTH

Hello Bill Leeney!

First of all, maybe it is known issue and for sure it is NOT fixed in Tamino 3.1.2 (I tested ‘argbatch’ on this version and it does not work, on Windows 2000 Pro).

However for only tested purposes (!!), I decide to delete Tamino 3.1.2 and install very old version Tamino 2.3.1 and …, ‘argbatch’ works!!!

I don’t really get how in old version this working, but the latest does not work. Maybe somebody can explain me that?

Thanks in advance!

best regards,
Dariusz Baumann

argbatch on old Tamino 2.3.1 version

I have been trying to use ‘argbatch’ on this 2.3.1 version of Tamino. I executed this command:
--------------
argbatch backup database target=localhost name=mydb
--------------

and I got the following message information lines:
--------------
Command started at: 2003-02-03 12:27:04
Running for product Tamino 2.3.1.1 on target node localhost.
---------------------------------------
| Job identifier = 0000000023708c06-00 |
---------------------------------------
Info: (INOAAI0468) Backup of database ‘mydb’ (2003-02-03 12:27:11)
Info: (INODSA1002) Tamino database handling 2.3.1.1 on Windows NT (2003-02-03 12:27:12)
Info: (INODSA1463) Database mydb accesssed online (2003-02-03 12:27:19)
Info: (INOAAI0620) Update backup generations of database ‘mydb’ (2003-02-03 12:27:22)
Info: (INOAAI0622) Update backup generations of database ‘mydb’ successfully completed (2003-02-03 12:27:22)

Command ended at: 2003-02-03 12:27:28
--------------
I thought that my backup file would be in directory:
C:\Documents and Settings\All Users\Dane aplikacji\Software AG\Tamino

However I cannot see my backup file.

I also checked in the registry database but didn’t achieve any success.

Where are backup files should be located of my database ‘mydb’?

Thanks in advance!

best regards,
Dariusz Baumann

Sorry you didn’t have any success Dariusz. The problem with argbatch is connected with using some Windows “Input Locales” - I guess you are using Polish and that’s one of the locales which has previously caused a problem. I know that this problem has been addressed so I can only suggest again that you contact your local Software AG representative and ask for the fix. Alternatively you can try to use another Input Locale (Control Panel, Regional Options, Input Locales and try UK) but I know that is a bypass and not really a solution for you. I don’t know whether you need to restart Tamino or your machine after you have changed Input Locales like this - you will need to experiment a little.

With regard to backups, Tamino backups are stored in the Location you indicate in the Tamino Manager. To see your backup location names, start the Tamino Manager, select Tamino, , Locations and you will see the Location Name of your Backup location for this database.

Now use Tamino Manager again, click on Tamino, Location Management and you will see the “Location Path” which corresponds to each “Location Name”.

In the “Backup” location path in your file system, you should find a xxxx.1b0 file which is your backup.

HTH