apache2 problem using apache2moduleino.dll

Hello,
I am upgrading to apache2 and cannot start apache with apache2moduleino.dll (latest for apache 2.0.35+)

apache error message:
"mod_ino.c is not compatible with this version of Apache…

After I comment out the section in the apache httpd.conf to load the ino module, apache starts up fine.
LoadModule ino_module modules/
apache2moduleino.dll

Specs…
WinNT
Tamino 3.1.1.4
Apache 2.0.39 (latest)
Apache Tamino module: apache2moduleino.dll

Any suggestions?
thanks
bob

Check out the following:

http://taco.software-ag.de/main/Downloads.shtm#communityReleases

The Tamino plugin distributed with the kit is I think only Apache v1 compatable.

Kind regards,

Simon

Hmmm. Maybe I misunderstood? You are already using this module? In which case I thought at the download site it suggests it should work so maybe you need to raise a request?

Kind regards,

Simon

I’ve the same problem with the INO-Module.
I have downloaded the module from the site, copied the file to the modules directory, inserted the LoadModule command in http.conf and then, Apache 2.0.39 is not able to start.
Is there any help`?

I’m seeing the same problem with the plugin for Apache 2.0 on XP professional with 2.0.39. Has anyone gotten it to work with either XP or this latest version of Apache?

…just found out that Apache’s module interface changed sometime between versions 2.0.35 and 2.0.39 rendering the Apache2ModuleIno.dll unusable on versions later than 35. So…stay with 35 until a new Tamino plugin release is available.

Update:
works with Apache 2.0.36

regards,

Timm

Solved…

…just found out that Apache’s module interface changed sometime between versions 2.0.35 and 2.0.39 rendering the Apache2ModuleIno.dll unusable on versions later than 35. So…stay with 35 until a new Tamino plugin release is available.

----------------------
So, when it will available Apache2ModuleIno.DLL for Apache 2.0.39?

:mad: :mad: :mad:

apache2moduleino.DLL -> only works using apache 2.0.35 !

:o :o :o

apache2moduleino.DLL -> NOT work using apache 2.0.36, 2.0.39 !

:frowning: :frowning: :frowning:

Best Regards
Dariusz Baumann

Just made same negative experiences with apache2moduleino.dll, Tamino 3.1.1.4 and Apache 2.0.40 under Windows 2000 Professional.

This means that all Apache 2.0.x versions > 2.0.36 are not supported by apache2moduleino.dll.

On the other hand Apache Group recommends not to use a version < 2.0.40 for securuty reasons. This means that we can not recommend any customer to use Tamino 3.x and Apache 2.0.x in a mission critical environment.

Is there a new version of apache2moduleino.dll according to the changed API of Apache in progress When can its release be expected?

As explained elsewhere …
Apache uses some magic cookie to ensure communication with the correct version of their internal interface. Alas the internal interface is not stable and still undergoes changes (each of these leads to a new magic number …)
So there were some internal API changes since 2.0.35.

I’ll try to provide a module for Apache 2.0.40 tomorrow. (Note: This won’t work with 2.0.39)

Regards,
Hermann

Is this module for Apache 2.0.40 available?

As discussed before there is some problem with Apache-Module using Apache 2.0.43. It doesn