ADABAS V6.1.4.04 on Windows Vista - CPU restriction

Hello, I have just installed ADABAS V6.1.4 on a Windows Vista (Ultimate) machine running 4 CPU’s and receive the following message on START of the Nucleus:
ADANUC-F-CPULIC, Number of CPUs restricted by licensing, CPUs online 4, CPUs licensed 2
Q: Is there any way to continue, since this machine is for personal use?

You might want to try to set processor affinity when you start adanuc, not sure if that works, but definitely worth a try

http://www.howtogeek.com/howto/windows-vista/start-an-application-assigned-to-a-specific-cpu-in-windows-vista/

Wolfgang,
Thanks for the weekend response ! I was pleasantly surprised !

I am a X-SAG mainframer so my PC skills may show a little here. :oops:

I am using the DBA workbench to get the database started. I am not sure how I can intercept the start of ADANUC from the workbench so that I may place in the /AFFINITY keyword. Is it possible to start ADANUC from the ADABAS COMMAND PROMPT? If so, what parameters is it expecting? (I assume something like the path and file name for the database.ini parms)? I tried setting the
affinity on the workbench, that obviously did not work because it appears ADANUC is really another process on the machine.
Thanks in advance,
Ken

Ken,

unfortunately I can’t try myself right now, I don’t have a Vista box ready, but yes, you can run adanuc “interactively”, you just need to redirect the input parm file accordingly.

You might want to take a look at the documentation in the “Administration” -> “Using Utilities” section.

Wolfgang,

I was successful in getting the affinity set to 1 CPU by modifying the STARTENV command script (for the ADABAS Command Prompt) as follows
@echo off
rem --------------------------------------------------------------------------
rem © Copyright Software AG 2008
rem
rem Start a Command Shell with the specific ADABAS settings
rem
rem --------------------------------------------------------------------------
call “C:\Program Files\Software AG\Adabas\v614\bin\adaenv.bat”

start /affinity 1 /b cmd

Looking at Task Manager I can definitely see that the number of CPU’s is 1 (CPU 0)
Then I started ADANUC in the window’s command like and got these responses after entering the parameters in by hand

Microsoft Windows [Version 6.0.6001]
Copyright © 2006 Microsoft Corporation. All rights reserved.

C:\Program Files\Software AG\Adabas\V614\BIN>adanuc
%ADANUC-I-STARTED, 22-SEP-2008 18:29:31, Version 6.1.4.04(03) (Windows)
adanuc: dbid = 1
adanuc: lbp = 100M
adanuc: logging =
adanuc: lwp = 1000000
adanuc: nt = 3
adanuc: noplog
adanuc: tnaa = 3000
adanuc: tnae = 3000
adanuc: tnax = 3000
adanuc: tt = 3000
adanuc: ^Z

%ADANUC-W-LBPLIC, Parameter LBP restricted by licensing, original LBP=104857600,
now LBP=16777216
%ADANUC-F-CPULIC, Number of CPUs restricted by licensing, CPUs online 4, CPUs li
censed 2
%ADANUC-I-IOCNT, 2 IOs on dataset ASSO
%ADANUC-I-ABORTED, 22-SEP-2008 18:30:50, elapsed time: 00:01:19

C:\Program Files\Software AG\Adabas\V614\BIN>

So bottom line is that I think the code is looking at the “physical” number of CPU’s in the box instead of what is assigned to the application. :frowning:

Any suggestions on how to proceed are appreciated.

Best Regards,
Ken