Response 255, then GDT access error after change to LAB

Greetings, I have been trying to get the adabas parameters set correctly, in Adabas on Suse/Linux, mostly the LAB since I have been getting response 255 (all attached buffers were allocated at the time the command was processed)about every 2-3 days. THis error causes me to cycle adabas. Can someone help shed some light on the subject of setting LAB to the correct value. I have had it set to 1 gig, but then went to 5 gig, got an error relating to not enough space available, then put it back to 1 gig, now I cannot bring adabas up. If someone can help I would greatly appreciate it. I currently have an open support request # 614319, but they have not resolved it as of yet. It has only been a week, but maybe someone here can help… thanks in advance.
I receive the following in my adanuc.log:
%ADANUC-I-STARTED, 15-JUN-2006 10:48:07, Version 3.3.2.02 (Linux 32Bit)
%ADANUC-I-PARSET, setting of ADABAS_ACCESS=ALL
%ADANUC-I-PARSET, setting of AR_CONFLICT=(ABORT)
%ADANUC-I-PARSET, setting of BFIO_PARALLEL_LIMIT=0
%ADANUC-I-PARSET, setting of BI=
%ADANUC-I-PARSET, setting of DBID=10
%ADANUC-I-PARSET, setting of LAB=10000000
%ADANUC-I-PARSET, setting of LBP=20000000
%ADANUC-I-PARSET, setting of LP=200
%ADANUC-I-PARSET, setting of LPXA=10
%ADANUC-I-PARSET, setting of LS=200000
%ADANUC-I-PARSET, setting of LWP=1000000
%ADANUC-I-PARSET, setting of MGC=50
%ADANUC-I-PARSET, setting of NC=200
%ADANUC-I-PARSET, setting of NH=10000
%ADANUC-I-PARSET, setting of NISNHQ=2000
%ADANUC-I-PARSET, setting of NT=10
%ADANUC-I-PARSET, setting of NU=200
%ADANUC-I-PARSET, setting of OPTIONS=(TRUNCATION)
%ADANUC-I-PARSET, setting of PLOG=
%ADANUC-I-PARSET, setting of TNAA=3000
%ADANUC-I-PARSET, setting of TNAE=3000
%ADANUC-I-PARSET, setting of TNAX=3000
%ADANUC-I-PARSET, setting of TT=3000

%ADANUC-F-MPGDTAE, GDT access error by adanuc/adadmn, reason: msg create
%ADANUC-I-IOCNT, 128 IOs on dataset ASSO
%ADANUC-F-STP999, STOP (, iopasync.c, SMP_SPINDEALLOC) - Error 16 during SMP call in line 895

A Rsp255 doesn’t always indicate a problem with attached buffers, check with ADAOPR DI=HIGH.

More likely it’s a problem with Linux resources, increase them (MSG* / SEM* / SHM*) as outlined in the installation documentation (“Increasing System V IPC Resources”)

NUC.LOG shows, that the start of ADANUC did not succeed. That’s due to
available IPC resources on your system. ADANUC seems to not clean up all
IPC resource at the moment, if there’s an problem getting IPC resource during
start.

To go further run 'showipc -kdf '. That should remove the
IPC resource.

Further if you’d like to set bigger LAP or LBP parameters you have to
configure Linux system parameter.
As root you can set the available share memory of 2GB with
echo 2048000000 >/proc/sys/kernel/shmmax
To examine current parameter value type
cat /proc/sys/kernel/shmmax

In /etc/sysctl.conf you can add these parameters, so that they are
set after every boot of the system.

By the way you can set parameters like shmmax, sem, msgmni, msgmax
and msgmnb the same way.

Thorsten, that did it, I gave the command showipc -kdf and it removed the shared memory… then I was able to bring adabas up. I will experiment more with the value of Lab and Lbp to see how to be rid of the 255 response.
A huge THANKS to you…
John Holt, DBA, Merced County