Accessing webapplications in MWS

Hi There,

We have an external web application that we want to host in our MWS and access it for some functionality.

We have deployed the war file into MWS, but I am not sure how we can access it ? ie open the JSP pages in that and utilise the same.

As i am new to these webapp in MWS side of things, any help is highly appreciated.


As far as I know it’s done the same way as it’s done in any other web container, I.e. by specifying the web app context and the rest URL. The context is by default the same as the war file name, if I’m not mistaken.

Thanks fml2* for the response.

I did tried accessing the web application the same way, but ended up in a page “Not Found” error.

For example, the context of the webApp is MyWebApp which has a jsp page called home.jsp.

I can see the .war file present in the MWS / Portlet-WebApplications. But when i access it like http://(actual Url):8686/MyWebApp/home.jsp" , we are getting the above error.

This web app has been tested working fine in Tomcat and not sure if the web.xml needs any specific changes for MWS.

That’s weird, I did access a usual server that way (not a Jsp page though). Maybe some necessary mapping is not present in web.xml? Or could it be that some Mws wide access rule gets active? In my case, I didn’t have to define any special rules to make the application accessible. Sorry for not being able to help more.

Thanks for your response fml2.

Here is what we have done

i. Open the UI Development perspective

ii. Create a web application with MyWebMethodsServer as run time.

iii Create the Jsp files inside the Web Content folders, WEB-INF/lib will have the associated jar files

iv. src/caf/war/applnName/ directory will have all the Java(servlet) code logic.

v. Export as war deploy into MWS (while deploying we got portlet container not initialised error)

Not sure how to progress further and are stuck at the moment and trying different options.

Hi all,

Just wanted to let know that this is now solved. The issue was due to how the server run time was configured.

I haven’t selected the Java Server Faces as the configuration while creating the project and kept it as “Default Config for MWS”

As soon as I changed it as Java Server Faces it started working . We are now able to publish it to MWS and access from browsers.