XML GW Wizard: doesn't start

Hi list,
I installed XML GWs but Wizard doesn’t start.
I tried with JWS 1.0.1, JWS 1.2.0_01 and JWS 1.4.2_03 with
JRE 1.4.0, 1.4.1 and 1.4.2

please note that, form my pc, JWS works fine with other examples (non XML Gateways).

The error I receive is:

An error occurred while launching/running the application.

Title: XML Gateways Web Service Wizard
Vendor: Software AG
Category: Download Error

Bad MIME type returned from server when accessing resource: http://sagiser:8080/wizard/app/XMLGateways.jnlp - text/html

and the exception is:

JNLPException[category: Download Error : Exception: null : LaunchDesc: null ]

at com.sun.javaws.cache.DownloadProtocol.doDownload(Unknown Source)

at com.sun.javaws.cache.DownloadProtocol.isLaunchFileUpdateAvailable(Unknown Source)

at com.sun.javaws.LaunchDownload.getUpdatedLaunchDesc(Unknown Source)

at com.sun.javaws.Launcher.downloadResources(Unknown Source)

at com.sun.javaws.Launcher.handleApplicationDesc(Unknown Source)

at com.sun.javaws.Launcher.handleLaunchFile(Unknown Source)

at com.sun.javaws.Launcher.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

this is very strange… :confused:

any tips is welcomed

Michelangelo Serpico
Software AG

+39 02950011.1
+39 3488205068

Hi all,
sorry for the above post, but the problem is so easy:
I forgot to change proxy setting to manula setting and exclude httpprox for “host machine name” and for “localhost”. I thought that it was enought to put “localhost” but during JBoss installation I inserted my “host name” other than “localhost”!

Michelangelo Serpico
Software AG

+39 02950011.1
+39 3488205068

I had the same error on my machine.
It is because the wizard is requesting a 1.4 Java virtual machine so you should check in Java Web Start configuration if such one is available.
Warning: although I used JWS shipped with a 1.4.2 JDK, the default configuration of this JWS was with a 1.3.1. So you should manually add the 1.4.2 one into the JWS one