XApp generation process freezes

X-Application Version: 4.1.1
Tamino Version : 4.1.4 Platform : WinXP
WebContainer : Tamcat 4.1.1
JDK Version : 1.4.2

Hi there
When I generate an new XApplication, after specifying the schema etc I click generate which takes me to the http://localhost:8080/xapp/generator/process.html page as per usual where you can trace the generation process in your browser window.

The generation starts fine then freezes at this point…

Processing status


Processing command: Generate

--------------------------------------------------------------------------------

generating
Preparing directory C:\jakarta-tomcat-4.1\webapps\PurchaseOrder
generating C:\jakarta-tomcat-4.1\webapps\PurchaseOrder\WEB-INF
generating
generating C:\jakarta-tomcat-4.1\webapps\PurchaseOrder\structure.xml
Success.
generating search.jsp

And it goes no further, it does not throw an error message.

When I execute http:localhost:8080/PurchaseOrder/serach.jsp the browser pag shows up totaly blank, although search .jsp is listed under the PurchaseOrder web app directory.

The only thing I can think of that I’m pretty sure it used to work with Java 1.4.0 and I’m now running 1.4.2

I guess it would help to add te Tomcat error message which says…

org.apache.xml.utils.WrappedRunTimeException: The output format must have a ‘{http://xml.apache.org/xalan}content-handler’ property!

Hello,

which Tomcat version are you currently using?

Could you post the search.jsp and the structure.xml of your Web application to the community (zip the two files because you can attach only one file).

Many thanks.

Bye,
Christian.

I think that’s a problem with JDK 1.4.2:

http://tamino.forums.softwareag.com/viewtopic.php?p=14130

Unfortunatly, there seems to be no work-around yet to make jdk 1.4.2 work …

Michael

Software AG Germany, Darmstadt

I thought it must be the JDK.
I have other java versions on my machine, where do I point the xapplication engine to another version? My version of Tomcat is 4.1.18. As I said, XApp only seemed to get this message after installing Java1.4.2 which I need otherwise my Tamino schema editor crashes.

You can add a
set JAVA_HOME=<path_to_jdk_1_4_1>
line to xapplication’s build.cmd script.

And: before launching Tomcat from the console, you have to adjust JAVA_HOME in this conle to a none-1.4.2 location.

Michael

Software AG Germany, Darmstadt

Setting the Java_Home to jdk1.4.0 in the Catalina Startup and shutdown.bat and also in the xapp/build.cmd file seems to have done the trick. THanks guys.
Don’t you just love Java version compatibility.