X-Applications Installation...

After I have installed the X-Applications, have changed the env.cmd and have runed the setup.cmd, no error messages were shown, so I thought everything was o.k.

If I start now the IE and insert the URL:localhost/tamino/xapplications
there is a xml-message:
“Tamino database unknown”.

What could be the problem?

thanks, pattrick

Hello Patrick,

did you create a database before and was the name of this database “xapplications” ?

X-Application’s setup does NOT create a database only the collection you specified in the env.cmd

After the setup you should see this collection within your database via X-Plorer or Tamino Interactive Interface.

The URL of the collection is then
http://localhost/tamino/<your database name>/

Tschuess Christian.

(Could it be you forgot the database name within your URL? :wink:

Hello pattrick,

I will move your topic monday to the Assistance Forum.

We would like to handle such questions and answers in the assistance forum.

Regards, Harald

[This message was edited by Harald Wolf on 14 Dec 2001 at 22:30.]

Hello back and thanks for your replies, but I still have a problem with this X-Applications:

If I enter the URL like I’ve written in my first post, it gives the error message “database unknown” what is comprehensive, because there is no database with this name, but if I enter the URL with a existing database and this database is running, it gives the following error message:
The page cannot be found!

Thanks patrick

Hello Patrick,

excuse me because of the insuffient information of my first reply.

If you want to address XML document with URL directly, you must address a document; otherwise you will receive the error message has you described.

The URL to address a document looks like this:
http://localhost/tamino/<your_db>/<your_collection>/<a_doctye>/@<a_ino_id>

After the setup of X-Application you should receive an XML document for a ‘Property’ with ino:id One:

http://localhost/tamino/<your_db>/<your_collection>/Property/@1

Did you also access your database with the new tools of Tamino?

I can recommend X-Plorer. A nice tool if you want to have a look for collections and documents.
Also the Tamino Interactive Interface is much easier to handle the in the former version.

Another way to check whether the installation of X-Application was successful or not, is the invocation of the simple exmaples for the jsp-tag-library. Look into documentation, there are only a few thinks to do (starting tomcat and entering a URL).

Hope, I could help you.

Tschuess Christian.

Thank you very much Christian, like this everything is working and I also installed the X-plorer which is a really interesting tool.

But I have a little problem with the Tomcat-Installation, because the JSP-Examples are not running, I always get the error-message:
Internal Servlet Error.

Do you know, what the problem could be?

And then I have another question:
I have users which are in special groups and this groups have special ACL. But if I give them “no rights” on a doctype, they can although enter with the URL on this doctype! Is this normal?

Thanks, patrick

[This message was edited by pattrick on 17 Dec 2001 at 10:06.]

Hello Patrick,

the error message is to unspecific for me to give a hint for your problem. Therefore, I would please you, to execute the following steps:

(1) start Tomcat within a separate window.
- open a console
- cd %TOMCAT_HOME%\bin
- startup.bat
(2) invoke the overview page of the simple examples
- http://localhost:8080/simple

(3) If this works, select the first example where the price of a Property is displayed

(4) As soon as the error occurs (within step 2 or 3) copy the complet output of your Tomcat window into a mail and post it to the community.

Perhaps, with the detailed output of the Tomcat window, we can find out your problem and how to solve it.

Thank,
Christian.

Thanks for your reply.

The error message in the console is:

x:>cd D:\tomcat\jakarta_tomcat

x:>startup.bat
’startup.bat’ is not recognized as an internal or external command, operable program or batch file

the error message from the browser, when I open one of the Tomcat-Examples:


à bientôt, patrick
X-Application Version: 3.1.1
Tamino Version : 3.1.1
Platform : NT, Win2k, Solaris, …
WebContainer : Tomcat 3.3
JDK Version : 1.3.1

[This message was edited by pattrick on 17 Dec 2001 at 11:39.]

1

[This message was edited by pattrick on 17 Dec 2001 at 11:40.]

Hello Patrick,

JSP technology needs a JDK to compile the JSP pages. JRE is not sufficient.
Please check the topic Using Tomcat of the Tamino WebDAV installation for further information.

Regards, Harald

[This message was edited by Harald Wolf on 17 Dec 2001 at 11:49.]

Hello Harald,

I’ve installed jdk 1.3.1 and the JSP-Servlet-Examples from the Tomcat are all running and also the WebDav-Server is running, only the other examples give this error message!

thanks
X-Application Version: 3.1.1
Tamino Version : 2.3.4.1 Platform : NT, Win2k, Solaris, …
WebContainer : Tomcat 3.3
JDK Version : 1.3.1

Hello Patrick,

please follow the following steps and report any difference and exceptions from the described behaviour:

  • restart tomcat
  • open the page http://localhost:8080/simple
    => A page with Heading “Simple Examples For JSP Tags” should appear.
  • Click the link “Hello” in the left column.
    => A page with Heading “Hello Example” and a body starting with “Price (element) : 130000” should appear.

Regards, Harald

Hello back,

If I enter this URL, there is another error-message: server or dns error. So what should work on this port 8080, the Tomcat-Server? On my machine he is on port 4000, but there are only this servlet-examples and one of this, is the example with the “Hello World” and this small examples are all working well.

thanks

Hello Patrick,

8080 is the default port number of Tomcat if you download it and do not change this default setting within the file

%TOMCAT_HOME%\conf\server.xml

When using WebDav the configuration of the delivered Tomcat version differs from the default configuration. The port number is 4000.

Therefore, try to invoke the URL

http://localhost:4000/simple

This URL links to the JSP examples of X-Application if the istallation was correct.

But before, restart your Tomcat as I described in my former mail and post the complet output of the Tomcat console window from the first line until the last line.

Remark: after starting Tomcat change the properties of the Tomcat console window:
- right mouse click on the top left corner of the window
- select menu entry ‘Properties…’
- select tab ‘Layout’
- enter new values for “Screen Buffer Size”, for example:
Height => 1500
Width => 300

Thanks,
Christian.