Error when accessing Xapplication

X-Application Version: 3.1.3
TaminoVersion :4.1.1,
Platform Solaris 8,
WebContainer : Tomcat 4.1.29
JDK Version : 1.4.1,

I receive an http Status 404 when attempting to access http://localhost:8080/xapp.

I have updated the version of tomcat according to the previous post. http://tamino.forums.softwareag.com/viewtopic.php?p=13883

Any other suggestions on why I’m receiving the 404 error.

Thanks.

Hello,

1) Please try out whether you Tomcat is running in general on port 8080:
- Insert the URL ‘http://localhost:8080’ within your Browser
=> The standard page of Tomcat should be shown.
If this URL fails look into the server.xml file of your Tomcat configuration directory and check which port is used.
Start the Tomcat in a console:
1.1) Change to …/tomcat…/bin
1.2) Invoke "catalina run"
1.3) Check if there is an error message when Tomcat is started


2) If the 1) was successful, look into the directory

.../tomcat-.../webapps



Is there a file called xapp.xml?

If no, an installation step of X-Application failed. There is one step that creates the context files to your Tomcat webapps directory.

If the file exists, please open it with a text editor and check the attribute value ‘docBase’ of the element ‘Context’. Does this path refer to a directory of your X-Application installation?

...xapplication_...\examples\jsp\ROOT



If also the check 2) is ok, I have no other idea what could be wrong with your installation.

Bye,
Christian.

step 1 is succesful. I get the Tomcat main page.
step 2 however: there is no xapp.xml file. Is it possible to perform that one steop of the install, the step that creates the context files to the Tomcat webapps directory?

Thanks

Hello,

there is one command that creates the xml file within your Tomcat home directory. To generate the file:

1) Open a console.
2) Change to the X-Application installation directory
3) invoke 'build1 setup.tomcat’

Is this step successful and does your webapps directory contain a list of XML files starting with xapp… ?

If not, please post the text of the console output to the community.

Many thanks.

Bye,
Christian.

When I try to execute ‘build1 setup.tomcat’ I get build1:not found. I check the permission on this file and they are “wide open” 777.

I even tried ./build1 setup.tomcat and build setup.tomcat.

What am I doing wrong?

Hi,

you’ll need to add the extension “.sh”: ‘build1.sh setup.tomcat’.

Bye
Thorsten

yes. I had the .sh extension. When I run build1.sh setup.tomcat I get “build1.sh: not found”.

When I run ‘./build1.sh setup.tomcat’ I get "./build1.sh: CMDLINE=setup.tomcat: is not an identifier"

Thanks

Hi Green,
when you execute the script via ./build1.sh … the standard shell is called. Unfortunately, this seems to be the “normal” shell, the script however needs the “Bourne” shell or “Born again” shell bash. Please try the following:
bash ./build1.sh setup.tomcat
Regards,
Gerald


Gerald Ristow
Tamino R&D

Making progress…when I executed
bash ./build1.sh setup.tomcat I get the following error:

Buildfile:ncconfig/build.xml
init:
BUILD FAILED
file:/opt/xapplication_411/ncconfig/build.xml:75: Please run setup before calling build

Hello,

is it possible with the tip of Gerald to run the setup.sh?

Bye,
Christian.

There is only a setup.cmd and setup.lock. I was told from a previous post that the setup.cmd is for Windows only.

I tried what Gerald suggested
bash ./build1.sh setup.tomcat

and got an error stating
BUILD FAILED
file:/opt/xapplication_411/ncconfig/build.xml:75: Please run setup before calling build

Hello,

excuse my. It was typo. I mean the command

build.sh setup



Bye,
Christian.

Ok…

./build.sh setup ran with the following error:

examples api:

[javac] /opt/xapplication_411/tools/bin/antRun:jikes: not found
BUILD FAILED
file:./misclib.xml:435: Compile failed; see teh compiler error output for details.

The log directory show this same output

Hello,

open the file build.sh with a text editor and adapt the settings for the Java compiler to your environment.

1) Disable the ANT option for the jikes compiler (remove -Dbuild.compiler=jikes)

ANT_OPTS="-Xms100m -Xmx512m"

2) Check the environment variable for the JAVACMD.

Is the environment variable for your JSDK correct? Look if JAVA_HOME points to an installed JSDK on your machine.

Invoke the setup again.

Bye,
Christian.

ok…the build seemed to work. I got build successful.

Then I launched http://localhost:8080/xapp. and I got the index.html page (X-Application Examples).

However when I click on “Simple” I get a 404 error /xappl.simple/index.html - the requested resource /xapp/simple/index.html) is not available.

Hello,

let’s check your webapps directory of your Tomcat:

I send the former post for the xapp.xml file. This file seams to be ok.

There are other xml files starting with xapp… that define a context for e.g. an example, the generator, a tutorial etc.

One of these files is xappsimple.xml. It defines the context for the simple example. Please, open this file with a text editor and check the attribute ‘docBase’ if the path for this directory is correct. It should point to

<your installation sub-dir> /xapplication_411/examples/jsp/simple



If the directory path is not a valid path, please correct the content of the attribute docBase.

For the next step is open a browser and enter the URL

http://localhost:8080/xapp/simple/index.html



The summary of simple examples should appear.

Bye,
Christian.

In the tomcat/webapps directory there are only 2 xapp* files (xapp.xml and xappdir.xml).

Is this to assume that something was not built correctly during the build?

Hello,

no. That is correct: xappdir.xml maps a context to the installation directory of X-Application (/xapp/dir) while xapp.xml maps a context to the root directory of X-Application’s web directory (/xapp).

Bye,
Christian.

My installation directory of xapplication is /opt/xapplication_411.
I have included the listing for xappdir.xml



<Logger className=‘org.apache.catalina.logger.FileLogger’ prefix=‘xappdir_log. ‘suffix=’.txt’ timestamp=‘true’/>


And for xapp.xml


<Context path="/xapp" docBase="/opt/xapplication_411/examples/jsp/ROOT"">
<Logger className=‘org.apache.catalina.logger.FileLogger’ prefix=‘xappdir_log. ‘suffix=’.txt’ timestamp=‘true’/>




I simply want to ensure I modify the correct file.

Should both docBase be set to: “/opt/xapplicaton_411” ???

Thanks for the help.

Hello,

these files are correct. I was talking about the file xappsimple.xml

Does this file exist within the Tomcat’s webapps directory?

If yes, check this file.

If it’s not created during the setup step, add this file manually with the following content

<!-- This file was generate by X-Application - do not edit! -->
<Context path="/xapp/simple" docBase=="/opt/xapplication_411/examples/jsp/simple">
  <Logger className='org.apache.catalina.logger.FileLogger' prefix='xappsimple_log.' suffix='.txt' timestamp='true'/></Context>



Bye,
Christian.