X-Application 4.1.1 build fails

Hi Taminoes,

My environment is:

Platform…: WindowsXP Professional
Tamino…: 4.1.1.1
X-Application: 4.1.1
Java…: 1.3.1_02
Tomcat…: 4.1.24 on port 8080
IIS…: 5.1

I’ve just unpacked and changed the xapplication.conf trying to use as much default parameter as possible (I had to change collection and doctype).

Please, could you help me to solve the exceptions below?

setup.collection:

defineSchema.internal:
[java] defining tsd schema: C:\DADOS\SAG\xapplication_411\testsuite\xmlfiles\property\property.tsd -> http://localhost/tamino/middle/store
[java] http://localhost/tamino/middle: connect failed – retry #0
[java] http://localhost/tamino/middle: connect failed – retry #1
[java] http://localhost/tamino/middle: connect failed – retry #2
[java] http://localhost/tamino/middle: connect failed – retry #3
[java] http://localhost/tamino/middle: connect failed – retry #4
[java] StoreException: id = 017 arg[0] = Error connecting Tamino: server not available.
[java] Nested Exception (com.softwareag.tamino.db.api.invocation.TCommunicationException, tag: $Name: JavaTaminoAPI_4_1_2_41 $) stacktrace:

[java] Nested Exception (com.softwareag.tamino.db.api.invocation.TInvocationRetryHandlerException, tag: $Name: JavaTaminoAPI_4_1_2_41 $) stacktrace:

[java] Nested Exception (com.softwareag.tamino.db.api.invocation.http.THTTPCommunicationException, tag: $Name: JavaTaminoAPI_4_1_2_41 $) stacktrace:

[java] Nested Exception (java.io.IOException, tag: $Name: JavaTaminoAPI_4_1_2_41 $) stacktrace:

[java] java.io.IOException: Server returned HTTP response code: 401 for URL: http://localhost/tamino/middle/?_diagnose=ping
[java] at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:562)
[java] at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:230)
[java] at com.softwareag.tamino.db.api.invocation.http.THTTPInvocation.getInputStream(THTTPInvocation.java:236)
[java] at com.softwareag.tamino.db.api.invocation.http.THTTPInvocation.doGetInvoke(THTTPInvocation.java:206)
[java] at com.softwareag.tamino.db.api.invocation.http.THTTPInvocation.doInvoke(THTTPInvocation.java:110)
[java] at com.softwareag.tamino.db.api.invocation.TAbstractInvocation.doTemplateInvoke(TAbstractInvocation.java:307)
[java] at com.softwareag.tamino.db.api.invocation.TAbstractInvocation.invoke(TAbstractInvocation.java:119)
[java] at com.softwareag.tamino.db.api.invocation.TAbstractInvocation.checkServerAvailabilityAndVersion(TAbstractInvocation.java:218)
[java] at com.softwareag.tamino.db.api.connection.TConnectionImpl.(TConnectionImpl.java:65)
[java] at com.softwareag.tamino.db.api.connection.TConnectionFactory.newConnection(TConnectionFactory.java:54)
[java] at com.softwareag.xtools.xapplication.store.TaminoStore.connect(TaminoStore.java:283)
[java] at com.softwareag.xtools.xapplication.store.TaminoStore.createStore(TaminoStore.java:231)
[java] at com.softwareag.xtools.xapplication.store.TaminoStore.createStore(TaminoStore.java:215)
[java] at com.softwareag.xtools.xapplication.schema.Define.defineTsdAndGet(Define.java:188)
[java] at com.softwareag.xtools.xapplication.schema.Define.define(Define.java:165)
[java] at com.softwareag.xtools.xapplication.schema.Define.main(Define.java:107)
[java] Exception in thread "main"
BUILD FAILED
file:./misclib.xml:243: Java returned: 1

Total time: 25 seconds




When I send “http://localhost/tamino/middle/?_diagnose=ping” it’s alive.

Thanx in advance,

Fernando Ito

Hello,

your Java version is 1.3.1_02. As I know the Tamino API for Java requires at least JDK 1.3.1_04 and X-Application is based on this API. Therefore, it could be a problem of the JDK version. We had a lot of topics about problems that could be solved by switching to a newer Java version.

Could you try out a new JDK and check if the error still occurs?

Many thanks.

Bye,
Christian.

I moved to jdk1.4.1_01 (because jdk1.3.1_08 didn’t work with Mediator) and the same error occurs… :frowning:

What can I do?

Regards, Ito

Hello,

when I understand your configuration right,
(1) you have installed X-Application on the same machine where your Tamino server is running and
(2) you have created a database with the name 'middle’

Please check if the database

’middle’

on your PC is correctly running. You can use the X-plorer of the Tamino Tools and connect to your database.

If this is successful, you could change the database URL ‘http://localhost/tamino/middle’ within the X-Application configuration file: Replace ‘localhost’ by the name of your PC and try to set up X-Application again.

- Open a console.
- enter ‘echo %java_home%’ if the home path for JDK 1.4.1 is correctly set.
- Change to the directory ‘C:\DADOS\SAG\xapplication_411’
- Invoke setup.cmd

That’s the only idea I corrently have.

Bye,
Christian.

Hello,

please post the xapplication.conf file to the community. I will have a look at it. Perhaps, I can find a configuration error.

Bye,
Christian.

Hi Christian,

Thanks a lot for your help! :wink:

I have got some progress on my installation. My X-Application built successfully. I had compiled it under Apache v1.3.22, because IIS does not connect to Tamino Server via Schema Editor nor X-Plorer.

My new problem is when I try to run the Simple example. I received an exception (HTTP Status 500). Furthermore, any JSP sample get this exception as well.

Observing my http://localhost:8080/xapp/index.html page, it seems that all sample folders should be under %X_Application_Dir%\examples\jsp\ROOT directory, but they are not.

Any suggestion?

Regards, Ito

PS: I’m sending the log file attached.
log.xml (39.1 KB)

Hello Fernando,

that is ok. The ROOT directory contains resource required by all WEB examples while the other directories (sample / invoice / property / …) contain the JSPs.

Have a look at your tomcat/webapps directory. There, you will find the xml files (xappproperty.xml) to define the context for the JSP examples.

To your error:
The error code 500 indicates that an exeption occurred during the JSP processing. The server is available. Could you post me the stacktrace which is sent with this error?

In combination with the log file you sent me I will try to find out the problem.

Many thanks.

Bye,
Christian.

Hi Christian,

Enclosed to this message is the stacktrace generated by Tomcat as you requested.

Thank you so much, Ito
Apache_Tomcat-4_1_24_-_Error_report.htm (7.11 KB)

Hello,

Thanks for the stacktrace you sent me. However, I could not extract the information I need to get a hint where the problem is located. The reason is that it is the stacktrace of a wrapped exception, but not the stacktrace of the original exception.

I sent a post to the assistance forum, how to get the relevant stacktrace. The idea is to include an error page that returns the requested information (stacktrace) as plain text. Therefore, my question to you: Could you

1) Download the error.jsp from the following link

http://tamino.forums.softwareag.com/viewtopic.php?p=14030

and copy it to the directory

…\xapplication_411\examples\jsp\simple

2) Change the page

…\xapplication_411\examples\jsp\simple\hello\Hello.jsp

by adding the errorPage attribute to the page declaration.

<%@ page language="java" contentType="text/html; charset=UTF-8" errorPage="../error.jsp" %>



3) Start Tomcat and invoke

http://localhost:8080/xapp/simple/hello/Hello.jsp

Perhaps, the stacktace that is returned now gives you a hint for the reason of your problem. If not, please send me the stacktrace that you received.

Many thanks.

Bye,
Christian.

Hi Christian,

The error.jsp file is unlegible (it’s not a plain text file). Is it ok?

By the way, I followed your instructions and I did not have any return from the page, just a little “forbidden” image (see attached error_jsp.gif). Is that what I should to get?
Thanx, Ito
error_jsp.GIF

Hello Fernando,

What are you meaning with ‘unlegible’?

If you question relates to the content the error page produces when generating the error message, it is plain text (content-type = text/plain). It is not HTML.

If you questions relates to the encoding of the file, it should be utf-8.

That you receive the ‘no access’ sign is strange. When the link does not work directly, please use

http://localhost:8080/xapp

However, before invoking the page make sure that Tomcat is running on port 8080. If you have another configuration use the port you specified (the default is 8080). On this page there are links to the examples also for ‘simple’.

If the links for these pages do not work, there is a mapping problem for context. In this case check the webapps directory of your Tomcat. There should be xml files starting with
xapp… for each example context. If these files do not exist, the installation was not correct and you have to start the command

build1 examples

Bye,
Christian.

Hi Christian,

Attached to this is a document showing the content of “error.jsp” after running Hello Sample. It turns to the “no access” gif. Strange, isn’t it?

There is also a picture with the errors that I get when I try to run “build1 examples” or "build examples"

PS: Tomcat 4.1.24 is started and the webservers (Apache and IIS) are stopped.

Regards, Ito
error_jsp_and_build_examples_cmd.doc (33.5 KB)

Hello,

please call

build1 examples

Bye,
Christian.

I have done it already. See the picture that I sent you in my previous message: at first, is the “build1 example” command and after that is the “build example”.

Thanks, Ito

Hello,

excuse me. My mistake. The call is

build1 examples.jsp

and for the API examples

build1 examples.api

Did you check the webapps directory of your Tomcat if it contains the xml files for mapping the xapplication context?

Bye,
Christian.