WmDB for SQL Server

I have a webMethods 6 server and a SQL Server Express on the same machine and I need to create a connection using WmDB.

I’m a bit lost in all of this and I can’t find the relevant documentation so I could use some help here. The SQL Server is \QDEURWM6\SQLEXPRESS.

So in the administration, in the WmDB, what should I use? Especially, what’s supposed to be the driver?

Then, I’d like to create a quick test using pub.db:connect service from the WmDB package, should I input the same information again in it? ($dbAlias, $dbURL, etc.)

This is my first post btw, and already asking for something :<

Thank you,

Try to find WmDB users guide in webMethods Advantage.

Choose the driver from loaded drivers drop down list, if not the server will use the default driver.

I think the dbAlias parameter is good enough to execute the service.

WmDB will eventually be eliminated. If you’re doing new dev work, the JDBC Adapter is the recommended path rather than WmDB.

Hi there, thank you for answering!

I think the problem is linked with Microsoft JDBC driver. I’ve copied the lastest MS driver to \IntegrationServer\lib\jars\sqljdbc.jar; but then, do I need to make something else so that this driver is taken into account?

Then what kind of URL should I be using for SQL Server, I’ve tried something alone the lines of:

For now…

If someone has a correctly configured WmDB adapter with Microsoft JDBC Driver, it’d be nice if they could share their config :stuck_out_tongue:


Self update: I could finally load the MS driver com.microsoft.sqlserver.jdbc.SQLServerDriver.

Now in WmDB, when I try to connect, the browser endlessly stays in “loading”. There’s no error in the log. Most probably, my connection string is wrong. I’m using:

jdbc:sqlserver://QDEURWM6\SQLEXPRESS:1433;databaseName=test in WmDB’s DB URL.

Self update: problem solved :smiley:

Correct DB URL for WmDB:

And we need to enable TCP/IP for SQL Server.