wM7.1 manager problem

hello evry one heres my problem

we are using wM7.1.1 version which is having(optimze for infrastructure)
Analytic Engine v7.1.0.0
Data Collection Services v7.0.0.2
Prediction Engine v7.1.0.0

task: to configure manager to monitor wM6.1 production and QA

every thing below is explained in reference mywebmethods interface

work done: setuped database pool ,defined environment and deployed it and then in administrator–> Mywebmethods—systemsetting—>defined analytical engine and it is connected(shows green dot) .
And in the manager box(where wM7.1 manager resides) started analytical engine,data collector,monitor and broker as windows services.

problem: So after doing the above steps now i need to add a component from wM6.1 so for that i navigated to Administrator–analytics–monitored components–discover
but in the discover screen i dont find any data collector. But if i go to administrator-system info it says both analytical engine and data collector are connected succesfully.If its connected then the datacollector should show up in the scrolldown box(we cant add it manulally)

please give me some suggestions and let me know if this is right procedure or not

thanks everyone

hello every one

i solved the problem .Actually i got confused between the infra structure data colllector and webmethods data collector.i thaught starting webservice data collector would start the infrastructure DC .But its not .You need to manually start the infrastructure data coll ( if its a windows application) in order to monitor the IS,Broker server , adapaters etc .

  Actually this concept is described in the documentation but its not at all clear .And honestly documenation is not at all good for infrastructure optimizer7.1 .We faced lot of problems with it .So please be consious 

thanks
Anil

hello

once again i am using optimize for infrastructure 7.1 for monitoring wM6.1 IS,broker etc

i more thing can any one guide me in defining a webservice as an alert action in rules.I read the documentation and defined a new webservice in developer6.1. And i went to the MyWMS7.1 and in the defined environment

Administrator–>systemwide—>environments

i went to the config server tabs and under anlytical engine -->WSaction settings i edited the config file .i gave the following

<?xml version="1.0" encoding="UTF-8"?> WS Action http://localhost:1234/Testpackage/new_testWS.wsdl new_testWS WMS service Administrator WSActionHandle ********

Next i applied this alert action in my rule . But when the rule is violated the webservice i defined is not executed .i am getting the follwing error

: Error sending context com.dante.analysis.action.template.context.ActionContextImpl@16fd15
(OPTIMIZE) [Analytic Engine v7.1.0.0 (1).com.dante.analysis.action.WebServiceAction.wsActionInvokeAction] 2008-06-27 14:27:44.58 EDT ERROR: electric.registry.RegistryException: could not bind to path: http://localhost:5555/Testpackage/new_testWS.wsdl
(OPTIMIZE) [Analytic Engine v7.1.0.0 (1).com.dante.analysis.action.WebServiceAction.wsActionInvokeAction] 2008-06-27 14:27:44.58 EDT ERROR: at electric.soap.registry.SOAPRegistry.bind(Unknown Source)
(OPTIMIZE) [Analytic Engine v7.1.0.0 (1).com.dante.analysis.action.WebServiceAction.wsActionInvokeAction] 2008-06-27 14:27:44.58 EDT ERROR: wraps: electric.http.HttpGetException: could not load:http://localhost:5555/Testpackage/new_testWS.wsdl
(OPTIMIZE) [Analytic Engine v7.1.0.0 (1).com.dante.analysis.action.WebServiceAction.wsActionInvokeAction] 2008-06-27 14:27:44.58 EDT ERROR: at electric.http.OutboundHTTPRequest.get(Unknown Source)
(OPTIMIZE) [Analytic Engine v7.1.0.0 (1).com.dante.analysis.action.WebServiceAction.wsActionInvokeAction] 2008-06-27 14:27:44.58 EDT ERROR: at electric.http.loader.HTTPResourceLoader.loadResource(Unknown Source)

thanks and sorry for the long post

Anil,

I have a query related to MWS.
I am not able to connect Task engine to the IS. I followed the steps in the pdf and used the sysadmin/manage credential both in MWS/System setting & WmTaskClient in IS. But in MWS, it is saying invalid credential.

Any help in this regard is appreciated.

hello

seems like task engine comes in optimzie for process(designer) .I am sorry my frend i did not work on it . But one fundamental suggestion i can give is that doc doesn’t lead you to the completet config ( becz i made lot of changes to my personal doc that webmethods doc did not provide) .Search for the error you are getting in the wM advantage site, Keep a SR to webmethods and apply latest fixes .
"And i think just as optimze for infrastructure is used to monitor wM compoenents like broker,IS,adapters etc the optize for process is used to monitor process models(designer) and task engine(work flow) ".Not sure but please correct me if i am wrong in the above quotes

Anil

Hello every one

i got the webservice working .Its just an ACL problem .I changed my developer ACL for generated WSD to ananymous and it worked any how here is the WS alert action template i used


WebService
http://hostname:6000/ws/fewParamWS:fewParamWSD?WSDL
Param


RuleName


RuleInstanceName


Attributes



Administrator
WSActionHandle
********


thanks

Hi Anil,

I am in a same boat as you were previously. I have passed the stage where I was unable to call webservice on rule violation but now I am not getting and variable(values) in my webservice. Is there anything which I have to set besides initializing the variables in input of the webservice like “RuleName”, “RuleInstanceName” etc ?