wM 8.2 Optimize for Infrastructure not able to discover Integration Server as an Assets


I am getting a Failed status in Optimize while discovering Integration Server (https) as a new asset with error ‘metadata not loaded’. However, broker server is discovered.

From wM 8.2 components point of view, we have the following components and environment has been defined properly in mws

  1. Infrastructure Data Collector
  2. Broker
  3. Analytic Engine
  4. MWS

I have tried to change the ‘Infradc.cnf’ file with metadatloaded=‘false’ and restarting it again. But still than, it’s not getting changed to ‘true’ after restarting Infra DC.

Please suggest me some inputs.


Hi Subhra Patra,

pls check the environment configuration at below path …

Define Environments > Edit Environment → select “Configure Servers” tab —> expand “Infrastructure Data Collector” → select “Collector Settings”

here verify whether you selected the option “Load Integration Server Definitions”

Thank You,
Naga Durga Prasad Ch.

1 Like

Hi Team,

My InfraDC running porerly @6699 port instead of 6666 default port.

Here my question is , when i am trying to select ‘Discovery’, i am getting InfraDC port number as 6666 and it showing as ‘infraDC@hostname:6666’.

May i know what might be the error.

please guide me on this

Hi Naresh,

You should have opend a new thread for your question.

Please provide your Optimize version with Fix-Level.

Please check your configuration files under InfrastrucureDC/config/.
One of these might containg the value you are looking for.

Additionally you might want to check under InfrastrucureDC/packages/WmInfra/config.

Unfortunately I do no longer remember the exact names or locations of them as we have migrated to wM 9.5 last year and are curently uninstalling the last wM 7.1 environments.


Hi Holger,

Thanks for Quick replay.
i am trying this in wm-9.9

And verified all the folders which u mentioned.

\SoftwareAG9.9\profiles\InfraDC\configuration\infraDC.cnf i am able to see config like below


i edited it and restarted my InfraDC but it changing to it’s old value.

Please suggest.

Hi Naresh,

when changing this setting you need to set metadataloaded=false before restarting.

Otherwise the data will not be updated in the database.



Had exactly the same issue with 912 and metadata property resolved it.