Weird issue between runtime and debug mode

I have a weird issue in QA/UAT. This works in Dev. The integration is between MfgPro and Siebel to retrieve Price details for an item on a sales order. MfgPro calls a webMethods provider Web Service which in turn calls a Siebel provider Web Service that is supposed to return Price Details.

 During runtime execution, the Siebel provider Web Service doesn't return line item price details, but, when I run the same data thru Developer in debug mode, the Siebel provider Web Service does return the line item price details.

 I have included tracePipelines to verify the results of the Web Service call to Siebel (as well as savePipelineToFile/restorePipelineFromFile to debug...)

 Does anyone have any idea why there would be a difference in what Siebel returns whether webMethods is is Runtime or in Debug mode ??



do you use any process model here? also reload the package once and test it…

May be ACL issue with the connector during runtime for the Endpoint?

Also are you getting the same result via soapUI?

Turned out to be a weird Siebel issue. Not absolutely sure what the Siebel Guys did, but, it’s now working the same at runtime as in Developer Debug Mode. Thanks for your help.

Glad to hear it resolved:)