Webmethods 9.12 to Amazon S3

Version: 9.12

Product with a customer License

I’m trying to connect from webMethods IS server 9.12 to Amazon S3 Bucket. I need to drop file or better to say put file in S3 bucket but i’m unable to do so as i’m getting signature did not match error.

I can’t use connectors as that will attract a price which client is not willing to pay.

Any other way i can achieve the above ?

Error: The request signature we calculated does not match the signature you provided. Check your key and signing method.

Can any one help or provide me code for AWS4 HMAC SHA256 signature.

Hi Rishi,

Attached is the sample code to authenticate AWS API requests sent by HTTP using Signature Version 4. Please use the service AWSAPIAuthentication.SigV4:signAwsRequestWithSignatureV4 to generate the signature.

Note: This package was created on 10.5. However, the code should work on 9.12 as well.

Please let me know if you have any questions.

Thanks,
Ram
AWSAPIAuthentication.zip (29.3 KB)

Hi Ramakrishana,

Thanks for replying.

I tried above service but still getting same error. Could you please help me to know
what input to provide in Canonical URI

image

will it be like below or something else

http://mybucket.s3.ap-south-1.amazonaws.com/

i tried to follow the example provided in AWS page but no help.

Thanks

Hi Rishi,

CanonicalURI is the URI-encoded version of the absolute path component of the URI—everything starting with the “/” that follows the domain name and up to the end of the string or to the question mark character (‘?’) if you have query string parameters. The URI in the following example, /examplebucket/myphoto.jpg, is the absolute path and you don’t encode the “/” in the absolute path:

http://s3.amazonaws.com/examplebucket/myphoto.jpg

​Let me know if you still have questions.

Thanks,
Ram

Please refer the below link for more details.

Thanks,
Ram

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.