Web Service using EntireX erx.dll error

Hello Group,

I have a VB.NET 4.0 web service I am trying to run. We are using software AG 8.2. When I run my web service on the servers it runs fine. However when I run it locally and try and debug it when the broker gets set up I get an error that says “20020011: Cannot load erx.dll”. This is the line of code it breaks on:

oBroker = New Broker(pstrBrokerID, pstrUserId)

I checked the BrokerID and the userID and both are correct.

I checked my local PATH variables and they seem to be correct with an entry pointing to “C:\SoftwareAG\EntireX\bin”.

Using very similiar code we connect to the broker successfully in a web page locally. It is when we try to run a service locally that we have the problem.

Does anyone have any tips as how to solve this?

Thanks in advance.

Did you install the EntireX “mini runtime” on that local machine ?

If yes - the correct variant (64-bit miniruntime on 64-bit Windows etc.) ?

Thank you for the quick reply.

We did not install the mini runtime. We do have a 64 bit windows 7 set up locally. We had to install the 32 bit entireX because we kept getting ERX.dll errors when trying to run anything in visual studio(even basic web pages that call the broker) when we had both 64 and 32 bit installs on there. Removing the 64 bit version of EntrieX cleared up the errors in visual studio 2010 for our web pages(but not the services).



I think the problem is too complex, to discuss it in the Community here. It seems to me, that you have a mixup of 32/64 bit EntireX versions. Please contact Software AG support and provide more detailed information about your operating system, IIS and .NET Framework version. We need also the exact version of the EntireX installation involved. It would be very helpful to get also the complete Visual Studio project with the web service.

With kind regards

The version of EntireX is 8, 2, 2, 0. We have thought of calling software AG but thought maybe I could get some guidance here first. It just seems odd that it works in a web project that contains the normal aspx(and code behind files) but doesnt work in a stand alone web service.

Visual Studio 2010 really blew up when we had both 64 and 32 bit client of Software AG installed. Wouldnt work for anything we tried. Read somewhere that VS 2010 only works for the 32 bit cleint so we did a reinstall of Software AG and only included the 32 bit stuff. Fixed our web pages but not the web services… again this problem only occurring locally. Works fine on the servers.

You have a problem in your configuration. We need the required information (see my previous comment) to analyze the problem. Please contact Software AG support.

With kind regards

Ok, thank you.

It’s a shame that this was taken offline - I have the same problem and was hoping for an answer.