Web Folder Problem

Hello,
I am having problem with creating Web Folder from MS Internet Explorer.
I am running MS NT 4.0 workstation SP6a. The Taminowebdavserver is running locally on my workstation. I can access it from MS Internet Explorer, via port 4000 or 80 (Apache).
When I try to install Web Folder to either URL, http://localhost:4000/taminowebdavserver or http://localhost/taminowebdavserver, I get a message "Internet Explorer could not open http://localhost:4000/taminowebdavserver as a Web Folder. Would you like to see its default view instead ?"
What’s wrong ?

Nevermind, I found out what was wrong.
I was running IE 6 on NT workstation without the MS Web Authoring Component installed. And since IE 6 doesn’t come with Web Authoring component, I have to uninstall IE 6, roll back to IE 5.x, install Web Authoring component, and then re-install IE 6.

Installed WebDavServer on Windows XP Prof, but not able to access via http://localhost/taminowebdavserver. Getting same error as below. Is the only workaround uninstalling IE6, and then installing IE5 with Web Authoring? And then upgrading back to IE6?

Is there a Web Authoring component for IE6. Did a search on Microsoft but did not find one.

Hi there,

which version of the WebDAV Server and Tamino are you using?

There is no port specified in your URL, so are you sure that the webserver is passing the request to Tomcat correctly?
(Do you have exactly the same problem - that it is possible to access the WebDAV server via http://…, but not access it as a web folder?)

Thanks,
Trevor.

Have tried it both with http://localhost:4000/taminowebdavserver and without the port #. Cannot access WebDav either from http:// or as a Web folder.

Get the following message when attempting to install MS Web folders: Internet Explorer could not open http://localhost:4000/taminowebdavserver as a Web Folder. Would you like to see its default view instead?

I’m running Tamino 3.1…4 and WebDav 3.1.2

typo: Tamino 3.1.1.4

Hi Mark,

just to fully understand the situation: what happens when you try to access the URI directly with IE 6 ?
(Not trying to do “Open File”, or “Open As Web Folder” - just trying to access the http address.)

Do you get the same error when you use the browser directly?

Is your server running behind a firewall, or is it somewhere that I could try to access?

Thanks,
Trevor.

This might help to find some information:
Start -> Programs -> Software AG Tamino WebDav Server 3.1.2 -> Server Error Log

The Tomcat logs can be found in “C:\Program Files\Software AG\Tamino\Tamino WebDav Server 3.1.2\jakarta-tomcat\logs” - perhaps one of them contains a useful error message…

TF.

Hi Mark,

an alternative to Microsoft WebFolders is WebDrive from South River Technologies (http://www.southrivertech.com).

This software allows the mapping of a WebDAV resource to a Windows drive letter.

Maybe this is worth a try…?

TF.

[This message was edited by Trevor Ford on 01 Aug 2002 at 15:48.]

[This message was edited by Trevor Ford on 01 Aug 2002 at 15:48.]

Hi Trevor,

I’m getting the following error message in the nt_service_jvm_stderr log file:

java.lang.reflect.InvocationTargetException: org.apache.tomcat.core.TomcatException: Root cause - Address in use: JVM_Bind
at org.apache.tomcat.modules.server.PoolTcpConnector.engineStart(Unknown Source)
at org.apache.tomcat.core.ContextManager.start(Unknown Source)
at org.apache.tomcat.startup.EmbededTomcat.start(Unknown Source)
at org.apache.tomcat.startup.EmbededTomcat.execute1(Unknown Source)
at org.apache.tomcat.startup.EmbededTomcat$1.run(Unknown Source)
at org.apache.tomcat.util.compat.Jdk12Support$PrivilegedProxy.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at org.apache.tomcat.util.compat.Jdk12Support.doPrivileged(Unknown Source)
at org.apache.tomcat.startup.EmbededTomcat.execute(Unknown Source)
at java.lang.reflect.Method.invoke(Native Method)
at org.apache.tomcat.util.IntrospectionUtils.execute(Unknown Source)
at org.apache.tomcat.startup.Main.execute(Unknown Source)
at org.apache.tomcat.startup.Main.main(Unknown Source)

Only just starting to work with Tomcat. How do you resolve this?

Thanks,
Mark.

Hi Trevor,

Got it fixed! Turned out there was a previous installation of Tomcat conflicting with installed Tomcat with WebDavServer. I had the other Tomcat install removed, and now it works as advertised!

Thanks for your help and feedback.

Mark.