Web Client In MFT

Hi,

As per my understanding web client is used to kick start the file transfer process in MFT, i.e. we configure the enviornment in MWS and we use web client GUI to start the uploading, dowloading or sharing the file transfer. The issue that I am having is I am not able to log in to web client GUI, with default administrator and manage credentials or my personal credentials. Its forcing me to log out after a moment I am logging in. Does any body have any idea what might be the issue. Is the default credentailas for web client is different from administrator and manage? if yes please share. I have attached the error screenshot.

Hi,

Web client is meant for end users to upload, download and perform other basic file operations. It is not an administrator interface and the default administrator/manage credentials will not work.

You have to explicitly define an user including the login credentials in ActiveTransfer Administration screens and login as that user through the web client. There are several other steps you need to perform as well. Define a virtual folder with access rights for the user, and define HTTP/HTTPS port in ActiveTransfer server management screens.

I have created a user and Given hima the MFT USer Permission. I have even given him access as user to to a particular folder in Virtual Folder Management and configured a https port also. Still I am getting the same error. Can you please give a step by step process.

Hi Aditya,

I guess you missed on role thing in MWS.

Please checkout the following [as per Active Transfer Guide, 9.6, page 40]:

To grant access, you must:

  1. Create a My webMethodsuser account.
  2. Define any custom roles you want to create for the user (see the following
    description of the default role).
  3. Define any custom roles you want to create for the user (see the following
    description of the default role).
  4. Add the user as a member of one or more ActiveTransferroles.

Please ignore if you are already done with role.

HTH.

Thanks,
Rankesh

1 Like

Hi Experts,

what are steps to grant MWS users access to active transfer UI. i already created a custom role added necessary permissions but still not able to access the active transfer UI .

If you are using ATS & ATG Both , then kindly verify the security.cnf file of ATS & ATG.

a) Shut down ATG and ATS
(b) Navigate to \IntegrationServer\instances\default\packages\WmMFT\config\security.cnf in both ATS and ATG
© If the values of “mft.ssl.certificate.file.name” is set to “builtin”, configure:-
mft.ssl.certificate.file.name=builtin
mft.ssl.privatekey.password=password
mft.ssl.keystore.password=password
(d) Start-up ATG
(e) Start-up ATS

Hi Aditya,

In MFT, when an user is given access to a Virtual Folder, the user can access any protocol to transfer files. If it is not working for you in HTTPs protocol, can you try the same with FTP protocol. All you need to do is to create an FTP port and access the port using any FTP client like filezilla.

This will help to narrow down the cause of the issue you are facing. If this works fine, the issue might be related to SSL configuration as suggested by Shahbaz above.

Thanks,
Bhaskar