Th package WmMFT is non responsive to Active Transfer

When i create a new intance for to Active Transfer have a problems and i try to connect with the Server Management my conection has the same structure Name: Default host: localhost and the integration server port: 5555 then i go to the Server Managment and show me the message says the package WmMFT is non responsive to Active Transfer

Help me…

Verify that you have changed the Active transfer instance URL from localhost to FQDN ) and the MWS SAML Resolver URL (in MFT Server) to the ip address of the machine.

Please check below:

  1. watt.server.auth.samlResolver is missing in server configuration in IS Admin Console > Settings > Extended please add as below. “watt.server.auth.samlResolver=http://:/services/SAML” and restart the IS server.

  2. Login to the IS server. Packages > WmMonitor > home check the MWS IP and port or correct configured.

  3. IS the Integration server and MWS Administrator password are same? if not do the same and restart the same.

  4. Under MWS - Administration -> My WebMethods -> System Settings->Servers click on Check Server Status. It should be Green

This configurations should be for activeTransfer server or activeTransfer agent? or both?
because I install activeTransfer agent and It generate a WmMFTAgent package but in MWS apeare the error "SOAP Exception: Check with your system administrator. My webMethods Server could not communicate with the ActiveTransfer Server named ‘Localhost’, because ‘WmMFT’ package is non responsive.

Can you check “Add the My webMethods Administrators role to MFT Administrator Role.”

and MFT/AT license key at installDir>/IntegrationServer/instances/default/packages/WmMFT/config/

1 Like

For the Active Transfer Server issue, Kindly mentioned the Active Transfer Server version and fix level.
Integration Server version.
Are you facing the issue with any specific tab of MFT or all MFT tab in MWS UI.
Check your JDBC pool for ATS and schema version for ATS must be 40

I can confirm, this helped resolve an related issue I was having in our setup.
Just one thing I would like to add as a recommendation, when you are defining “ActiveTransfer Instances” especially if they are on a different server - than the host server for MWS set the “WebService Timeout” as say 20 to 30 secs - just so as when there are delays in communication it will not timeout and process without giving error especially when certain page have more load time.