Visual Studio cannot browse CentraSite CE

Hi all,

I’m new to webMEthods products. We are currently exploring CentraSite CE (v.8.2.2) and we’ve been trying to set up the UDDI connection between Visual Studio 2010 and CS.
I provided our developer with the given URLs:
http://:53307/UddiRegistry/inquiry
http://:53307/UddiRegistry/publish

Our developer was able to connect to CS UDDI (inquiry) with his user account and all but he only sees the default services provided by SAG and not the ones we developed/published from Designer (v.8.2.2).

Since there is no technical documentation on this subject (at least, not that I could find) and SAG does not provide support for CE version, I’m not sure if I’m missing some settings or what we do wrong here.
Any help or suggested documentation/direction would be greatly appreciated.

Regards,
Dao

Hi
Are you using UDDI v2 or v3? For v2 due its missing security concept you need to change the asset permissions to be visible to “Everyone” group.
Which tool/Plugin where you using to access?

Daniel

1 Like

Hi Daniel,

Thanks for a quick response.
I believe we’re using v2. That’s what I have in the UDDI Global Configuration properties. Where else can I check to find out?
Our developer was using ‘Add Service Reference’ (from VS2010) to access (attached screenshot).
The thing is, since we are new to CS, we don’t know if that’s the way it’s supposed to be or if we’re using the right tool from VS2010. I was expecting that he would be able to see all the publsihed WSD as we see them from Designer (attached screenshot).
I changed the asset permissions in CS as suggested but it’s still the same, he only sees the 4 default UDDI services from CS.

Regards,
Dao


UDDI - Designer.jpg

Hi Dao,

In the designer screen shot, I could see that the services published to the different organization than “Default Organization”. Therefore, If a service has “view” permission for “EveryOne” group and it is not visible to the UDDI v2 Inquiry request then the uddi request has other parameters set in the inquiry call.

In this case, the organization is set to “Default Organization” it seems. Please verify the organization settings in the UDDI tool (VS2010) for inquiry.

Please try to publish a sample service to the “Default organization” and give “View” permission to “EveryOne” group. If it comes in the VS2010, then it is surely UDDI inquiry call used organization as parameter.

Bet Regards,
Karthik S

1 Like

Hi Karthik,

Thanks for your inputs. We tried to publish a sample WSDL to the Default Organization and gave ‘View’ permission to ‘EveryOne’ group as suggested. Unfortunately, the outcome is the same. In addition, there seems to be no parameter we can select/change in the ‘Add Service Reference’ window (VS2010) at the time of the call.
What I’d like to know is whether it is possible and how we can connect to CS from VS2010 to browse the services/WSDLs which were published from Designer. Is there any additional/special settings, configurations that I should be aware of, etc.

Regards,
Dao