Version error in application builder

What product/components do you use and which version/fix level?

10.11

Are you using a free trial or a product with a customer license?

license

What are trying to achieve? Please describe in detail.

I uploaded the application builder SDK (through npm) on my enterprise (management) tenant and getting version error. I tried to upload (SDK npm) the same application builder in sub tenant also getting same error.
With the error I can not add application and many more.

I’m trying to upload one application builder (through SDK npm) in management tenant and subscribe that application builder to sub tenant, so that I don’t have to upload separate in other tenant .

Do you get any error messages? Please provide a full error message screenshot and log file.

Have you installed latest fixes for the products

1 Like

Hi Saif,

what is the reason for deploying the Application Builder using npm and c8y cli? Why don’t you use the zip archive from the github repository?

What commands did you run to build and deploy the Application Builder?

Best regards
Christian

1 Like

Hi Christian,

I’m using npm to deploy the Application builder to Cumulocity because I have setup custom role access in Application builder (app-builder-navigation.service.ts). This custom role restrict user to access specific dashboard in application.

To build - npm run build or c8ycli build
To deploy - npm run deploy or c8ycli deploy

Thanks

Hi Saif,

when you build the Application Builder it is important to run the build script. If you simply run c8ycli build it will build the Application Buillder application, but won’t apply the webpack configuration. It’s important that the webpack configuration is processed during the build, as it also sets the __Version__ variable. Therefore, make sure to run npm run build inside the Application Builder project.

I have just tested it myself and could you reproduce your issue, when I build the Application Builder using c8ycli build. When building it using npm run build everything is working fine.

Can you double check and try to build it one more time using the command npm run build.

Best regards
Christian

1 Like

Thanks Christian. The issue is “c8ycli build” command.