Getting error on running c8y client cli

Hi, I am using cumulocity free trial version and I was following this documentation Getting started - Cumulocity IoT Guides. I am currently getting Error occurred while trying to proxy request /tenant/loginOptions from localhost:9000 to (UNABLE_TO_GET_ISSUER_CERT_LOCALLY) ( [HPM] Error occurred while trying to proxy request /tenant/currentTenant from localhost:9000 to (UNABLE_TO_GET_ISSUER_CERT_LOCALLY) ( [HPM] Error occurred while trying to proxy request /user/logout from localhost:9000 to (UNABLE_TO_GET_ISSUER_CERT_LOCALLY) (

this error on my terminal of vs code when I am starting the application. I am running this app on my office laptop so I think this issue might be cause of some restrictions, but I am not able to resolve this issue. Please let me know if you know anything about the same.

Hi Samanyu,

It seems like you are not trusting the GoDaddy CA.

You can set the NODE_EXTRA_CA_CERTS environment variable and point it to the CA certificate of GoDaddy.

Another not recommended option could be to set NODE_TLS_REJECT_UNAUTHORIZED=0 but this insecure as the certificates would not be validated.

Hi Tristan,
I was able to fix that error but currently i am getting issue when i am trying to deploy my application with c8y cli.

npx c8ycli deploy
prompt: Instance URL:  (
prompt: Username:  (admin) NewUser2
prompt: Password: 
Create application failed:
Error: Failed to connect to Invalid credentials provided or tenant not reachable.   
    at DeployCommand.createClient (C:\Users\samanyu.mehra\my-c8y-application\node_modules\@c8y\cli\dist\cli\DeployCommand.js:253:27)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async DeployCommand.action (C:\Users\samanyu.mehra\my-c8y-application\node_modules\@c8y\cli\dist\cli\DeployCommand.js:72:31)

This is the error on my vscode terminal. I am providing the correct username and password but still getting invalid credentials error, can you tell me what the potential issue could be.

Hi Samanyu,

please try to remove the trailing “/” in the URL:

Hi Stefan,
Already tried that but same issue. My user has all the roles present in the cumulocity and I have tried changing password and using the same for deployment but no luck. Can you tell me what else I can do to make this work?

The user is case sensitive, are you using the correct casing?

Hi Tristan,
Yes I have a user with the name of NewUser. Check the image attached.


Hard to do remote analysis but sometimes one of the following is the reason for that error:

  • The username & password are case sensitive. (Make sure caps-lock is deactivated, copy & paste user + password etc.)
  • Try to login with the user + password you are using in the browser and check if that is working.
  • When browser is working but CLI not it could be because direct connections are not allowed by a corporate policy and you have to use a proxy or use a computer where direct connections are allowed. Found this: GitHub - reubenmiller/c8ycli-fork: Fork of the @c8y/cli to add support behind corporate proxies but is pretty old.
  • The URL is wrong (make sure you use (copy & paste it from the browser).
  • Permission admins role is sufficient (which has the application admin role).

Hi Stefan,
I have already tried all the points you have mentioned except the 3rd one so I am currently following that. Let’s see if that’s the issue, I will update you guys here.


Is it possible to deploy the application with cli on cumulocity trial version because everything is working with other mediums except c8y cli so could this be a potential issue?

You can build the app with c8ycli build.
Afterwards you should have a dist folder. Navigate to where the cumulocity.json file is, normally apps → {app-name} and zip everything to a zip with the app-name.
In cumulocity you can go to Administration → Ecosystem → Applications → Add Application (Top right) → Upload App. Select the zip and you application is deployed to your tenant.

Hi Stefan,
I know we can build from cumulocity on the browser but my issue was that I need to deploy through cumulocity cli. I tried deploying it from my personal laptop and I was able to deploy it so I think the office laptop has some restrictions regarding the credentials in cli. Anyway thanks for your help and your team.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.