"c8ycli deploy" asks for tenant

I am trying to deploy an application I created using the C8Y CLI.

I try to run the c8ycli deploy command which then displays the deployment wizard in my terminal. According to the deployment process I need to provide it with my tenant URL, username, and name.

However, now it’s also asking for my tenant and I am not sure what to provide it with. I have supplied it with my tenant ID, the tenant name that is included in my URL, and tried to skip it by simply hitting enter, but regardless it returns the same error message:

Create application failed:
  res: Response {
    size: 0,
    timeout: 0,
    [Symbol(Body internals)]: { body: [PassThrough], disturbed: false, error: null },
    [Symbol(Response internals)]: {
      url: 'https://novanta.us.cumulocity.com/tenant/currentTenant',
      status: 401,
      statusText: 'Unauthorized',
      headers: [Headers],
      counter: 0

I have full admin rights, so I am not sure why it would return a 401 error at all.

Can you show the full list of prompts it demands?
What version of c8ycli are you using?
c8ycli --version

Hi Lucas,

The c8ycli only asks for a tenant, when the initial attempt to connect without it, did not succeed. The tenantId is meant in this case with tenant (it usually starts with t followed by a sequence of numbers). In your case the tenantId should be: t491610964.

It seems that the credentials you are using to connect are invalid.
Please keep in mind that the username and password are both case sensitive and that you cannot login with SSO credentials.


Hi Tristan,

I found out the solution. I was trying to paste my password into the command terminal when it did not allow me to. I re-entered the password manually and it worked.



This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.