Login error when developing Cumulocity cockpit application

I am trying to create an application using the cockpit scaffold with the latest c8ycli version: 1018.0.205

I have been following the tutorial for extending existing applications and have been able to build the application; however, when I try to access the application via localhost:9000, the application displays a login and authentication page that does not accept my Cumulocity credentials.

I then tried to implement the changes from the next tutorial to remove the login page and authentication, but I keep getting the same error in my console:

Is your credentials working fine when used directly on tenant?

And how are you starting your local server?

Normally you are prompted for tenantID, username and password of your target tenant. How did you start the local server?

What does the Network tab of dev tools show for the http 401?

Yes, I am able to login without a problem onto the Cumulocity tenant.

Yes, I am prompted for all three of them. I start the local sever with the npm start command.

Which tenant and which user are you trying to connect to?

You are using npm start -u https://<URLtoYourTenant> right? -u is the important flag that needs to be provided.
Otherwise it will point to demo.cumulocity.com which will not work.

Ah, I forgot about that part. It works now. Danke schon!

1 Like