Urgent!Help Needed-ODBC Error

Can I how to solve this error:

<?xml version="1.0" encoding="windows-1252" ?>
<ino:response xmlns:ino=“http://namespaces.softwareag.com/tamino/response2” xmlns:xql=“http://metalab.unc.edu/xql/”>
xql:queryContact</xql:query>
<ino:message ino:returnvalue=“8505”>
<ino:messagetext ino:code=“INOXME8505”>ODBC error occurred</ino:messagetext>
ino:messagelineState: 42000Native Error: 156 [Microsoft][ODBC SQL Server Driver][SQL Server]Incorrect syntax near the keyword ‘FROM’.</ino:messageline>
</ino:message>
</ino:response>

I’m trying to query using the Interactive Interface and I got this error. I think there’s something wrong with the table name. The table name is with spaces.

Here are my settings:
Datasource - Microsoft SQL Server:StudentPortal
Table - Cyansys Pte Ltd$Contact
MS SQL Server 2000
Tamino XML Server 3.1.1.4

Everthing is fine if I uses a table which has a single name. (eg. Contact)

Please help :confused:

Isn’t there any solutions to my above question? anybody please reply… :frowning:

Hello ,
can you please post the schema you are using for the ODBC access.

Regards,
Uli

This is my tamino schema… I just think there is something wrong with the table name but this is the default settings I get when I use the ODBC wizard… I can define it successfully but cannot query it…

hope u can help…
schmContact.TSD (2.26 KB)

You need to change the schema in the following ways:

1. The table name needs to be quoted i.e
Old:
table=“CyanSYS Pte Ltd$Contact"

New:
table=”“CyanSYS Pte Ltd$Contact”"

2. The column “No.” also needs quoting.

3. If “Name” is mixed case then it would be safer to quote it - though in this case it is not necessary.

Regards,
Gary

I tried putting quotes as what you’ve explained but i got an error saying this when I tried to define the schema:

<?xml version="1.0" encoding="iso-8859-1" ?>
- <ino:response xmlns:ino=“http://namespaces.softwareag.com/tamino/response2” xmlns:xql=“http://metalab.unc.edu/xql/”>
- <ino:message ino:returnvalue=“8906”>
<ino:messagetext ino:code=“INOXSE8906”>XML parser failure for schema definition</ino:messagetext>
ino:messagelineLine 26, Column 55: XML parser: not well-formed</ino:messageline>
</ino:message>
</ino:response>

Can anybody explain what other methods that can resolve this? Thanks

Sorry, I did not notice that the escape sequence quote had been replaced by the actual quote character.
Enclosed is your schema with the appropriate modifications…

Regards,
Gary
schmContact.xml (2.3 KB)

alas… i can make query from Tamino without any errors. It’s the quote character that is missing. Thanks Gary! :slight_smile: