UNIX Natural Program Editor

Hello, I am no longer able to use the Windows Natural Editor so am forced to use the UNIX natural editor but am struggling with how to enter a new line in the editor and also how to unlock a locked object, been struggling to find any answer to this for some time and is now urgent so any assistance would be greatly appreciated

Have you tried using the Line commands documented in this portion of the Unix editor manual?


It seems to be similar to the mainframe editor, but not quite. The doc seems to indicate you type line commands over the line numbers (prefix area) starting in column 1. So to insert a line, type I over the line number where you want to insert, or I3 to insert 3 lines, etc. That causes blank line(s) to be created that you can type into.

If the line numbers area is protected so you can’t type over them, you have to use the PROTECT OFF editor command to unprotect them.


Not sure about the LOCK issue. Is that like a checkout function to protect source from being edited by 2 people? Probably best to give your DBA or Natural support person a call.

Since you aren’t working with SPOD anymore, maybe any future questions would be better posted under the Natural on Open Systems forum, where the Natural Unix programmers hang out.

Hope that helps. Good luck!

If you have experience with ISPF, you will notice that many line commands are the same: Copy, Delete, Insert, Repeat, …

What version of Natural for Unix are you using?

Is Natural Security installed?

Thank you George,
the link helped with how to apply the line command so am able to make the changes I need, much appreciate.
I am still unable to Unlock Locked objects, it is a checkout function to prevent others accessing the object but if the session closes it then remains locked. In SPoD you could Unlock locked objects but I cannot seem to find out how to do this from the server.

Hello Ralph,
I am not familiar with ISPF but have resolved the editing issue thanks to George, just the Unlocking now. We are still on a very old version of natural, 5.3, for which the SPoD on windows does not work on Windows 10, looking at older versions of SPoD which would run on Windows 10 do not support 5.3 hence my problem.

  • ISPF is IBM’s mainframe IDE/editor with which many Natural developers are familiar.
  • Natural Security can be set to prevent you from using the UNLOCK command.
  • Natural 5 is ancient, but I am a bit surprised that it isn’t compatible with newer versions of Windows. Isn’t this a licensing issue? Have you asked SAG for an updated license key?

Hello Ralph,
Yes, very old…We did contact SoftwareAG but was told we would have to upgrade, due to internal business issues this was not practical so have been having to use the UNIX editor. Not sure about the NATURAL Security, I have always been able to do it via SPoD so assumed it would be the same on UNIX, not sure how to check


You have my sympathy. It’s never any fun losing a favorite program editor. Many mainframers are going through your situation in reverse, forced off the old Natural editor onto NaturalONE and its windows-style text editing.

Ralph is probably right about the UNLOCK command. You probably just need Natural Security permission on the NDV server to use it. A search for UNLOCK turned up this reference in the Natural Security manual.


Good luck,

The SYSPROD command will tell you whether Natural Security (NSC) is installed.

Also look for Predict. Lock records are stored in FDIC if Predict is installed. Otherwise they’re in an FDIC clone called the Natural Development Server file.

Hello both, really appreciate you continued advice.

Ralph, if I run SYSPROD I get the below:
Natural 6.3
Natural IDL Generator 6.1
Natural Development Server 2.2

I have found a directory called FDIC but the files in there are of the format PRDNNN.XXX, are these the lock files?

My Company is also on an older Nat-Version@Solaris10. We got a compiled Natural-Program from Software AG one day called UUNLOCK . Works good so far. Please ask your support for that…


I’m a bit confused, you still have NDV, so why can you no longer use SPoD / the Windows Editor ?

Unlocking objects is meant to be done from SPoD or ONE, not from the Linux environment,
although, as Matthias says, there is a special solution which has to be requested from support.