Unit Test Framework - Authorization Required: [ISS.0084.9001] Invalid credentials

Hello,
I wanted to run unit tests via the Unit Test Framework. I followed the guide from the documentation 10-3_Unit_Test_Framework.pdf, but when i run the test, I get the following error:

The server log says (yes, there is a quistionmark, dollar sign and two fours ):

In the designer Preferences -> Software AG -> Integration Servers, im successfully connected to the localhost server as Administrator.

Anyone knows whats wrong, should I put the credentials somewhere else too?

There is no separate place to define credentials for Unit Test Framework test execution other than “SoftwareAG > Integration Servers” Preference page. Unit Test framework, basically, uses same credentials as defined in preference page while executing the tests.

Are you able to connect to localhost server with this specific user in Preference page ? Do you see this error only while running the tests and not while connecting the server from Preference page ?

Additionally please note, Designer Unit Test Framework executes tests against ‘Default’ Integration Server (Check “Default” column of Integration Server definitions table in Preference page in Designer) only. Please also crosscheck the “Default” server is correctly defined in case you have multiple connections.

Yes exactly as Sanjib pointed out please make sure your Default (connection settings to that remote IS) is the one you are using or have setup multiple connections with respect your UT framework is referencing to and causing this Auth issues.

HTH,
RMG

thanks for response,
Yes, I checked the credentials in the Preferences and also the default connection. Everything is OK and the Designer can connect (as Administrator) to the IS (proof in the Attachment). In the Service Development perspective I can also edit/run the service I use in the unit test.

I tried uninstalling/installing the Unit Test framework through the 10.3 installer. No luck.

Please confirm you are using latest fixes available for Designer Service Development and Unit Test Framework.

Are Unit Tests failing with Administrator user or the other user "? $ . 4 4 " ?

Could you please also upload the Junit failure stacktrace (available in Junit view) and also the test console (from Designer’s console view), so i can have a look.

Im using the latest fixes for Unit Test Framework - release 10.3.0.0001-0010

There is no user named "? . 4 4 " never was , im running the tests under Administrator (confirmed) after a clean install. So this way i don't know why the IS server log is reporting > Authentication of user "? . 4 4 " failed.

The JUnit stack trace is an initialization error. Screenshot in attachment…
The Designer console is empty.
The failure trace only shows one line:

Annotation 2020-03-19 091733.png