Uninstalling a specific component using command based mode

Hi Al,

If we want to uninstall a specific installed component using command based mode, how can we do it.

I used java -jar SoftwareAGInstallerxxxx_1.jar… to install webMethods components and did all components using commands as I don’t have GUI capability on my RHL server. If I wanted to un-install, I tried the same command

java -jar SoftwareAGInstaller201202_179.jar …
which is showing like below :

Select a new item to install by entering the item number. [X] marks items to install; [#] indicates a partial installation. [I] marks already-installed items.

You will be able to select language packs (if available) later.

Install? Product name Size


  1. [ ] Select All
  2. [ ] Adapters
  3. [ ] webMethods Enterprise JavaBeans Adapter 6.5.2
  4. [ ] Program Files 1 MB
  5. [ ] Documentation 2 MB
  6. [ ] Templates 48 KB
  7. [ ] webMethods EntireX Adapter 8.2 SP2 5 MB
  8. [ ] webMethods for Microsoft Package 7.1
  9. [ ] Code Generator 1 MB
  10. [I] webMethods JDBC Adapter 6.5

But it is not having any thing to un-install a specific component, can someone help me on this. Kindly let me know if there is any other script we have to use to un-install a specific installed component.

Thanks,
Anil.

Hi Anil,

the SAG Installer is not intended for uninstalling components.

You can find the uninstaller in your installation directory in the bin directory.

/bin

There is a script called uninstall.
This has a command line mode similar to the one the installer is using.

uninstall -console

Regards,
Holger

Thanks for your response.

I found the script uninstall @ /softwareag/bin directory. If I wanted to un-install JDBC, can you please share me the steps.

Thanks,
Anil.

Can you please also share me any documentation pdf which has these details. Thanks a ton for your help.

Hi Anil,

here are the steps:

  1. shutdown the IS
  2. run uninstall script
    a. select the JDBC Adapter by giving the number
  3. complete the uninstall
  4. restart the IS

You can find the Documentation in Empower or in the TechCommunity (http://techcommunity.softwareag.com/ecosystem/communities/public/_communities/documentation).

Eventually you have installed the Documentation component along with the products.
Then you will find the documents in your installation directory under _documentation.

Regards,
Holger

Thanks Holger for your help.

I tried to access the link which you shared but I am getting ‘Access to the requested resource has been denied’ error. If you have this specific document handy, can you please kind enough to share it with me.

Thanks,
Anil.

Hi Anil,

please request acces to the documentation section by using the following link:

http://techcommunity.softwareag.com/ecosystem/communities/protected/contents/documentation-access/index.html

As I am usually log in via SSO with my Empower account, I am able to access the mentioned pages.

Regards,
Holger

Thanks Holger for your help. Followed the same. Un-installed the MWS, re-installed it again, created tables once again after which can able to see MWS is started working. Thanks a lot.

At present IS, MWS are running fine but Broker is not coming up.

I followed the below steps:

./broker_start :6849 & ( to start broker, replaced hostName with IPAddress of machine )

after which I got the below statment.

The host ‘192.168.43.69’ was found, but no Broker Server monitor is running on port 6850 of that host

Tried to start broker Monitor with below syntax :

./broker_start hostName:6849 -monitor_port 6850 &

After which I got the below statment.

The host ‘192.168.43.69’ was found, but no Broker Server monitor is running on port 6850 of that host.

Can you please me to make the broker server up and running.

Thanks,
Anil.

Good to hear your MWS issue is resolved. Even I was not aware to un-installing a component using script.

Use below one under Broker directory, you can see broker should up.

./S45broker82 start &

Let us know the result.

Thanks,

Thanks MR, it is up n running.

Thanks,
Anil.

Hi all,

I have one thing to check:

When installing IS, does webMethods store anything as part of tables related to IS… The reason,as I changed the database which is completely new, created tables using DBCC, not copied anything from old DB, just modified files under JDBC/pool folder for IS. And when I started IS, it started up and running. But for MWS i supposed to install it again. Can some one confirm on Integration Server behaviour.

Thanks,
Anil.

Hi,

IntegrationServer requires only a very few data to be present in the database prior to first startup as it is storing most if its configuration/data under the following directories:

  • IntegrationServer/config
  • IntegrationServer/audiit/data
  • IntegrationServer/DocumentStore
  • IntegrationServer/WmRepository4
  • IntegrationServer/XAStore

Only the Package WmTNWeb requires a specific entry to be set manually in the table IS_DATASTORE as it will not create/update its own configuration otherwise.
But this packages is deprecated and does no longer exist in versions wM 9.x and newer.

Not all of the directories mentioned contain static data, some are only buffering directories between IS and Database/Broker/UM.

Not all of them apply to all current wM versions.

The IS might throw an exception during startup when the MWS-Schema (used for CentralUsers function) has not been initialized yet or is not accessible at all maiking it impossible to monitor proeses et al. in MWS.

The MWS is working the other way round, because it is storing most of its configuration in the database except for those files which are placed in the file system explicitly.

Therefore when planning to point the mws to a new schema it is either possible to get the schema exported from the old db to the new db (assuming they are of same type and version) or re-configure the MWS againts the empty schema after a reinstallation.

After uninstalling MWS it is recommended to recreate the schema prior to do the fresh installation as it can be that the installation script tries to create some data in the database during installation (this is definitely true when installing Optimize, as earlier versions of the Optimize UI created the neccesary tables during the installation instead of having them included in the DCC/DBS-scripts for “PRODUCT MWS”).

Regards,
Holger

Thanks Holger for your information. What I observed was, it didn’t have schedulers details which were created earlier. Though the triggers are exist, they didn’t work well, so supposed to create the new one.Modified JDBC connections under JDBC in IS admin page.

Thanks,
Anil.

Hi Anil,

the schedulers are stored in the database in the table IS_USER_TASKS.

For the Triggers check the directories I have mentioned.
Take a backup of these (except config) and delete their contents.
Restart IS afterwards.
The content will be recreated then.

Regards,
Holger

Thanks Holger for your comments. At present existing interface is working fine. If in-case any issues will follow the one which you specified.

Thanks,
Anil.

Holger,

I have enabled auditing in case of failures which earlier recorded the failed transactions which I was able to see from MWS. But now, though the service got failed, I am unable to see the transactions. Can you please suggest what changes should I do to see audit the transactions in case of failures.

Thanks,
Anil.

I fixed the prob.