unable to start Integration server due to JDBC pools issue


I am using below environment and IS version

OS: Windows Server 2008
Integration Server (ver: 9.0)

When I start the Integration Server, its not coming up and I am noticing below things

  1. IS server logs having ‘[ART.0115.3709D] Adapter Runtime (Listener): Listener Manager waiting on Integration Server initialization.’ invariably. This happens when wmART, WmARTExtDC gets loaded by IS package manager while booting. I also observed that all the packages are getting loaded but its finally waiting for IS configurations (to get from wM DB) to iniatilize all DB releated stuff (ex. JDBC connections)
  2. I suspect there is some issue with JDBC pools (i.e. functional alias definitions not able to associate pool alias definitions). I found this when I start the IS in safe mode and when I open JDBC pools in safe mode I see functional alias are not working and I have to restart all the functional alias to get it online

But how do I fix JDBC pools when I run IS normally?

We had a network upgrade recently and after this we are facing this issue for your reference. (I am able to connect wM DB using SQL DEVERLOPER client successfully and no issues with wM DB).

I am also attaching the server logs for your reference. Also attaching the jdbc pools page (opened in IS safe mode)

Please help, its very urgent.

Thanks in advance

server log file.txt (209 KB)

Is this a new wM install and did it worked correctly previously and before network upgrade or after upgrade?

Can you also try uninstall the IS and resinstall the instance fresh?


Hi Saba,

has this IS started successfully at least once?

Can you share the JDBC-Pool Alias part of the JDBC-Pool config page?

Under IntegrationServer/config/jdbc/ you will find the corresponding config files:

  • functions contain the associations between functions and pools. 1 XML-File per function
  • pools contain the pool definitions with the connections details for these. 1 XML-File per Pool

Maybe one or more of these files got corrupted somehow.

Under the IntegrationServer/config/backup/jdbc you will find copies of these config files form last successful startup of the IS. You can try to copy these back to original location and restart.
In most cases this solves such sort of issues.

From the Server log there are several error messages related to the JDBC-Adapter Connections.
Some seems to have incorrect credentials, some seem to have a non-existing target server (“Io exception: The Network Adapter could not establish the connection”) or DB-instance (unknown SID).

Are your internal schemas also located on this DB(s)?

Please make sure that you have the latest SCG_9.0_SPx_DataDirect-Fix applied to your server.
This contains the driver that is used by wM internally.

Additional Information:
Archiving wont work with your current settings as the Archiving functions operate on the same table names as the original auditing tables (for IS Core and Process Audit). Create a separate Schema/Pool Alias for the Archiving Component and set the parameter in the table OPERATION_PARAMETERS accordingly. See Monitoring Guide for details and further settings.

Please check the provided log-file carefully as there a several other errors there like a duplicate ‘<’, which causes services to not be loaded and not being visible in Designer for further development.
Fix these errors and try to restart the IS.

If you have further questions we will try to answer them.

Your are welcome.


Yes please troubleshoot and try the above options and let us know how it goes.