Unable to read Email attachment from service invoked by IMAP


I am currently developing a service which is invoked by E-Mail Port (IMAP) to read data from attachment or body of the email.

Without attachment I am able to read the body of the email (multipart message) using the following services.

→ pub.flow:getTransportInfo
→ pub.mime:createMimeData
→ pub.mime.getBodyPartContent
→ sample.mime.helpers:streamToString
→ pub.string.stringToBytes

and writing the values into a file

No value is coming up in the pipeline if attachment is in the email. I need to read the attachment of the email.

Many thanks for any help offered.


Hi all ,

My requirment is to read a attachment from Email and send it to an FTP Location.

I have Successfully configured a Email Port Listner , and it is in enabled state also . I am consistently getting an error as under

[21411]2006-01-25 10:40:16 EST [ISP.0068.0024W] The connection to the IMAP server (MY SERVER NAME) for user (MY USER) was temporarily lost. Some messages may not have been processed. swapRows();writeTDnowrap(“row-l”);[21410]2006-01-25 10:40:11 EST [ISP.0068.0005W] Error processing email message. * BYE Connection down.

I tried to Enable and Disable the Listner port but of no use . Has anyone came across such problem .

thanks in advance for your help


did you find a solution for this?

We ahve the same error while migrating from 6.0.1 to 6.5, and using IMAP.

Kind regards,


Hello Joshi or Jeroen,

Did you find a solution for your problem with the IMAP connection?
We have exact the same problem on our webMethods 6.5 and
at webMethods support they can’t find any solution for it.
Could you or someone else help me futher?

With kind regards,


It seems the problem is caused by SP2. webMethods is creating a fix for this which solves the problem. I tested an early pre-release and this was working ok.



I’m facing the exact problem in 6.1. I’m unable to read the attachment contents of the email in WM. My email listener is enabled and the gobal service is invoked, i’m also able to read the body of the email but am unable to read the attachment contents. There is no content object appearing in the pipeline. Will be really helpfull if you can share your thoughts on this.

Thank you,