Unable to login into API Gateway - The username/password you entered is invalid

Hi All

I have installed API Gateway thru sag docker image and when i tried login into the api gate way its throwing "The username/password you entered is invalid erro"r. Below is the error message in the IS server log.

[353]2018-07-03 04:44:42 UTC [ISS.0053.0002C] Access denied for user GatewayInternalTechnicalUser on port 5555 -> ‘invoke/apigateway.ui:getSolutionDetails’ from 127.0.0.1.
[352]2018-07-03 04:44:42 UTC [ISS.0012.0022C] Access Denied. Authentication resolved to user “GatewayInternalTechnicalUser”. User is not defined in any of the available user stores.
[351]2018-07-03 04:44:27 UTC [ISS.0053.0002C] Access denied for user GatewayInternalTechnicalUser on port 5555 -> ‘invoke/apigateway.ui:getSolutionDetails’ from 127.0.0.1.
[350]2018-07-03 04:44:27 UTC [ISS.0012.0022C] Access Denied. Authentication resolved to user “GatewayInternalTechnicalUser”. User is not defined in any of the available user stores.
[349]2018-07-03 04:44:12 UTC [ISS.0053.0002C] Access denied for user GatewayInternalTechnicalUser on port 5555 -> ‘invoke/apigateway.ui:getSolutionDetails’ from 127.0.0.1.
[348]2018-07-03 04:44:12 UTC [ISS.0012.0022C] Access Denied. Authentication resolved to user “GatewayInternalTechnicalUser”. User is not defined in any of the available user stores.
[347]2018-07-03 04:43:57 UTC [ISS.0053.0002C] Access denied for user GatewayInternalTechnicalUser on port 5555 -> ‘invoke/apigateway.ui:getSolutionDetails’ from 127.0.0.1.

Looks like GatewayInternalTechnicalUser doesn’t have access but expected this user should be created automatically when I run the docker img but not sure whether the SAG docker image is correct one or not.

Here is the reference for the SAG docker path: https://store.docker.com/images/softwareag-apigateway

Can someone please suggest if any manual steps are required upon API gateway installation.

Thanks
Guru

I have tried Administrator/manage

Check if this user exists and also check the jdbc pools for “isinternal”.

Can you share the IS details with fixes?

I have installed this from a apigateway container not thru empower licensed img.

There is no such user. Just wondering if its due to wrong license?

The license file will expire 2018-07-15 23:59:59 UTC as per the IS container.

I do not see any errors after starting the docker container “store/softwareag/apigateway-trial:10.2” I am able to login with Administrator/manage and no errors reported on IS server/error logs.

The moment you see the error, can you capture the screenshots of “Server > Statistics > Sessions”.
We would require more details to check what is wrong?

Hi Mahesh

I have given a try again by creating a new container but no help.

I ran the docker run -d -p 5555:5555 -p 9072:9072 --name apigw store/softwareag/apigateway-trial:10.2 command for kick start but skipped memory setting command sysctl -w vm.max_map_count=262144 from the docker img instructions.

IS is up but APIGateWay is not up and can see errors in the logs. attached few screens

sent screenshots to your email, could you please find it.

APIGateway will not be up until elastic search is up and running, for the elastic search to startup you have to set “sysctl -w vm.max_map_count=262144”

Before you start the container, set “sysctl -w vm.max_map_count=262144” and start your APIGW container and you should be able to access APIGateway without any issues.

Make sure “WmAPIGateway” is loaded fully and not partial.

Hi,

please check the IntegrationServer server.log file to find out why the package has been loaded partially.

After fixing the cause for this partial loading, reload the package or restart the instance to get it working.

Regards,
Holger

If you intended to use the API Gateway docker container from docker store on Windows using Docker Toolbox, to start the Elastic Search set the below configs

docker-machine ssh
sudo sysctl -w vm.max_map_count=262144
exit

Thank you guys, i missed to run the sysctl -w vm.max_map_count=262144 before starting the container.

Able to access the API GW now.

Hi, i’m facing similar problem, i can’t login into webmethod api gateway.

I already follow all the instruction given in here https://store.docker.com/profiles/ardinugraha/content/sub-bc3c2971-25a4-4dea-bd8c-59290555ee09

but still can’t login.

Please advise.