Unable to create TOPIC in UM - 9.6

Unable to create TOPIC under UM 9.6. I get a security errors and it creates a CHANNEL but not a TOPIC.

Not sure hold the earlier team worked on this.

Please help.

Go to UM Enterprise Manager, select the umserver and go to security tab, check ACL and give access accordingly.

1 Like

Thanks but that was not the issue. Issue was that the ANALYST who did the install used his domain name rather than a service account and since he has left the organization it stopped us from going ahead.

Changed to service account , recreated all realms and it started working now .

Thanks for your feedback.

1 Like


I am also having trouble creating Topics/Channels.
There are 3 ways that I know of to create them.

(1) Via Enterprise Manager - Left hand side of screen eg Right click on the Realm name > Create Channel

(2) Via Enterprise Manager - Click on Realm name, then on right hand side click on JNDI tab, click Apply, Right click on Topics and create a new one.

(3) Via Designer when defining a JMS Trigger.

The problem I am having is that triggers defined by options 1+2 don’t appear in Designer when creating a trigger.
And option (3) fails with an error (attached)

Any suggestions? Or any doco on best practice to creating Topics?

Many thanks in advance.



For me it was not working as the consultant who created the UM using his own domain account has left the company and the domain account was disabled.

So had to create it using a more generic account and it worked.

Try that out. seems little finicky as the message did not have details.


Hi Stephen,

  1. please make sure if the JNDI Connection Alias you created is able to perform lookup on the UM using “Test Lookup”
  2. If JNDI lookup is successful, then test your JMS Connection Alias by trying to enable/disable it

If above two are in place and working fine then you can use any one of the first two ways you mentioned in your post to create a topic/channel. Then you have to go to JMS Connection Alias and enable/disable your connection alias again so that the connection will be refreshed and you can see the topic/channel you just created at the time of creating trigger.

Hi Prasad,

Thanks for your response.
The JNDI Connection Alias is connected. It can do the lookup. The problem is the results it returns (eg list of Topics and Queues) does not match what is in UM Enterprise Manager! Eg there are ones which have since been deleted that show up in JNDI, and also new ones that are in UM EM that do not appear in JNDI. Something is wrong…

I have since applied all patches to UM (UM version 9.0, webMethods version but it hasn’t helped.

Next I will see if there are fixes available for the UM Enterprise Manager.
Definitely something not right…


I think the problem is: Topics and Queues still exists on UM. Try the below steps:

  • Log into UM EM with correct UM Realm name
  • Select UM Realm and go to JNDI tab(mostly last one)
  • From JNDI tab check the Topics and Queues, if it exists remove them and do a JNDI lookup on IS.
  • If the problem exists restart UM

Let me know if you still have questions.

Hi M@he$h,

I installed the latest fixes for Nirvana UM 9.0 that we have installed, and also tried using the Enterprise Manager version 9.5 which appears to be identical to the 9.0 version except for the icon.

I still have issues.

If I follow your instructions I get intermittent issues. Sometimes I can add a Topic via the JNDI lookup and all works fine. However I usually get an error. See: UM Enterprise Manager - failed to add topic in UM EM

Also adding Topics via Designer fails 19 times out of 20. See: Designer - Failed to create Topic

So far the only way I can see to add Durable topic is via Designer. No way to do it in EM that I can see.



I think it is a JNDI lookup error. Intermittent failures. Perhaps network related? Although the IS and the UM are on the same box in development.

See the attachments. When I click on APPLY to refresh the JNDI lookup, 19/20 it will fail.

Creating topics only works 1/20 as well. So it must be some sort of connectivity issue. However they are on the same machine! (IS + UM)

I have raised a case to SAG for more help.


Do you see any errors on nirvana.log? Please check.

Thanks for all your help. In the end, SAG recommended that we upgrade from UM 9.0 to UM 9.9.

We did that and everything is working as expected!