Unable to build X-Application 3.1.3

X-Application Version: 3.1.3
Tamino Version : 3.1.1
Platform : WinXP Pro
WebContainer : Tomcat 4.0.4
JDK Version : 1.4.0_01

I have followed the installation instructions, but always get the following result… Anyone can help me? (Tamino is not yet installed on this machine, but I think it is not required in this step, is it?)

D:\Tamino\xapplication>setup

D:\Tamino\xapplication>build setup
Buildfile: ncconfig\buildLib.xml

BUILD FAILED

No JAXP compliant XML parser found. Please visit http://xml.apache.org for a sui
table parser

Total time: 2 seconds
Buildfile: ncconfig\buildLib.xml

BUILD FAILED

No JAXP compliant XML parser found. Please visit http://xml.apache.org for a sui
table parser

Total time: 0 second

Hi there.

Could you please take a look into the /prerequisites/lib/ext directory and tell us which Jar files you find there?

Thanks,
Trevor.

httpunit.jar
jdom.jar
log4j.jar
servlet.jar

Those 4 files are in /prerequisites/lib/ext

BTW, no files in /lib/ext

Thanks in advance!

Hmmmm, that’s interesting! JDK 1.4.0 actually packages a JAXP compliant parser in the rt.jar file, so I suspect that the error is caused by the X-Application build process.

I was fortunate enough to get a pre-release candidate, in which there were three extra files in the prerequisites directory.

I will post those files here. You should copy all three into prerequisites/lib/ext then try the build again.

Cheers,
Trevor.

File #1.
xml-apis.jar (106 KB)

File #2.
xercesImpl.jar (1.65 MB)

File #3.
xalan.jar (885 KB)

Thanks for the files. But it still failed to build.

I forgot to mention that a window popped up after
"Buildfile: ncconfig\buildLib.xml" line appeared. The error message shown in the window is
“C:\WINNT\system32\ntvdm.exe” error occurred while setting environment for the application. please click “close” to terminate this application."

(My WinXP isn’t English version, but I translate the msg into English above)

Hi there,

there was another posting regarding problems with XP: here.

I’m afraid that I have no Windows XP version available, so I can’t offer any help in that regard.

Sorry,
Trevor.



I have solved the problem, you can take a look at that place.
Anyway, thanks for those useful helps … :slight_smile:

Another problem while building…

===================

setup.collection:

defineTSD:
[java] reading tsd file D:\Java\Tamino\xapp\testsuite\xmlfiles\property\pro
perty.tsd
[java] http://xxx.xxx.xxx.xxx/tamino/xapplication: connect failed – retry #0
[java] http://xxx.xxx.xxx.xxx/tamino/xapplication: connect failed – retry #1
[java] http://xxx.xxx.xxx.xxx/tamino/xapplication: connect failed – retry #2
[java] http://xxx.xxx.xxx.xxx/tamino/xapplication: connect failed – retry #3
[java] http://xxx.xxx.xxx.xxx/tamino/xapplication: connect failed – retry #4
[java] error: connect to Tamino failed: id = 161 arg[0] = Error connecting
Tamino: server not available.
[java] NestedException: Server not available.
[java] NestedException:Server not available for http://xxx.xxx.xxx.xxx/tamino/
xapplication because of a deeper exception
[java] NestedException without message!
[java] aborted.

BUILD FAILED
file:./misclib.xml:226: Java returned: 1

===================


Where “xxx.xxx.xxx.xxx” is another Windows 2000 server on which Tamino is installed.
I have an administrator account and can login this machine through
http://xxx.xxx.xxx.xxx:9991/ (System Management Hub). Did I miss something to setup?

Hello,

did you check whether the database ‘xapplication’ is installed?

The installation process of X-Application is able to install collections and schema, but prerequisite is an existing database.

Use the Tamino X-Plorer or Tamino Interactive Interface to browse your database.

If the database does not exist this is the reason for the problem.

You can use an existing one (normally there is a pre-installed database called ‘welcome3_1_…’) by changing the Tamino URL within the xapplication.properties file.

Instead of http://xxx.xxx.xxx/tamino/xapplication, use http://xxx.xxx.xxx/tamino/welcome3_1_….

Bye,
Christian.