Trading Networks: How to enable "PROFVAL_Profile" Document Type?

Hi experts,
I am getting following expeption while I am creating the Profiles for my EnterPrise and Partner profiles on Trading Networks.

Profile Data Error
(1) Profile has errors. Saved with a status of Inactive.
(2) Unable to validate the profile because the “PROFVAL_Profile” Document Type has been disabled. Please enable the “PROFVAL_Profile” Document Type.
(3) Error encountered invoking wm.tn.profile:addProfile com.wm.app.tn.profile.ProfileStoreException: webMethods Trading Partners is restricted to the creation of one profile in addition to your own.

Help is appreciated,
Thanks in Advance.

-Venkat.

Venkat,

you can log in to the TN Console and click on the document types and then click on “Show Enabled/Show all” button then it will list all the doc types. Now select the doc type and click on the enable button (light bulb).

Cheers,
Akshith

Hi Akshith,
I tried to enbale PROFVAL_Profile from document types, but no luck.
I had enable the PROFVAL_Profile from documents, but it is not working still showing same message when ever you active the profile.

Thanks,
Venkat.

Venakt,

Can you post the whole error dump from the TN console?

Hi Akshith,

When ever I am trying to active profile from TN console, one popup is opening along with this error message.

Profile Data Error

(1) Profile has errors. Saved with a status of Inactive.

(2) Unable to validate the profile because the “PROFVAL_Profile” Document Type has been disabled. Please enable the “PROFVAL_Profile” Document Type.

(3) Error encountered invoking wm.tn.profile:addProfile com.wm.app.tn.profile.ProfileStoreException: webMethods Trading Partners is restricted to the creation of one profile in addition to your own.

2.Return value for ProfileStore.getProfileStore().getMyId() is null

Thanks,
Venkat.

Venkat,

I am not sure…but this might help you

https://advantage.webmethods.com/advantage?targChanId=kb_home&oid=1612163122

Hello Akshith,

It’s not working, Is there any other way to enable the “PROFVAL_Profile” Document Type.

Help is appreciated, Any body pls…

Thanks,
Venkat.