Trading Networks Deliveries getting stuck in PENDING status

We are experiencing a sporatic problem with our Trading Network deliveries (posts and ftp’s) getting stuck in a PENDING status. The only way to get them out is to re-start the server. Has anyone else run into this or knows what causes it?

Reduce the wait time and check!

Murugaiyan, Can you be more specific please. Do you mean on the B2B Server or within Trading Networks.

On Trading Networks we have:
Retries: 3
wait time: 0
Max Retries: 3

Please help

If the wait time is 0 I dont think of any other solution. You can try this double click on the document it will open the activity log there you can get the error messages. Based on the messages we can do something about it. It seems some problem in the profile.

We’ve faced the same probkem Michael. We’re talking to webmethods for a solution. BTW, which server are you running. We got this problem on our 4.0.1 B2B server with TN version 4.

If you run wm.task.shutdown and wm.tn.task.init - it will restart the deliveries in most cases.

We are on the same server set up: 4.0.1 B2B server with TN version 4.
I have an open issue with WM Support too, so hopefully a permenant fix will be coming.
Thanks for the suggestion - i’ll try it next time we encounter the problem!

Mike

I ran into the same problem. We were running 4.0.1 as well and delivering via ftp. The tasks would go into a PENDING state, but would eventually complete after 1-2 hours. webM suggested it may be a problem with the JVM. By upgrading to JDK 1.3.1 the problem was resolved.

We upgraded to JDK 1.3.1 and are still experiencing the PENDING issue. Did you do anything else in conjunction with the upgrade?

Thanks,
Mike

No, did not do anything additional w/the 1.3.1 upgrade. However, some other things to consider:

  1. If using a custom delivery service, does the delivery service actually complete? I’ve seen where a failure of a custom delivery service will leave a delivery task in a pending state.
  2. Check the logs (audit, error, server). Are you able to determine what else is running?
  3. Disable the action/processing rule that ftp’s the file. ftp direct from B2BServer to see if that works.
  4. There is a patch for pending jobs on server startup (TNS_4-0-1_FIX_8); don’t know that this would help, but it’s a known problem

Thanks,

There are no failures on the delivery and nothing in the logs.

I’ll try the patch and also try to ftp directly, but we’re also having problems doing http posts?
Did you have this problem also or just with ftp?

We installed TNS FIX 8 but it didn’t fix the PENDING issue completely in B2B/TN 4.0.1. Apparently, it does not exist in B2B/TN 4.6 , which is what we’re testing at the moment

Sonam,

You are correct. The fix was for TN4.01. We applied the patch to our TN instance and so far so good. BTW, we are running TN with B2B 3.6 if this helps.

ray

We have the patch applied, and we have the new JDK 1.3.1 installed but we’ve still experienced the problem. (And the Shutdown/Init service isn’t working for us)…

I’ve put it back on WM’s support group to come up with a concrete solution.

If anyone has ANY other ideas, please let us know.

Thanks in advance.

Ray - Looks like running 3.6 helped you. :slight_smile: Like the other guys, we were running B2B 4.0.1 and the PENDING issue didn’t fully go away.

Mike - sorry friend - your best bet may be 4.6. We tried patches, task manager shutdown/inits, even special debug code from support… the only thing that got rid of the PENDING issue reliably was a full server restart.

However, our incidence did reduce to about once a month We were processing hundreds of documents a day. (I think this issue does get worse with load.)

Right now, we are testing B2B/TN 4.6 - we have not come across the same problem in B2B 4.6. However there is a different issue - duplicate TN deliveries - that had been addressed in 4.0.1 and is now reincarnated in 4.6. Product development are writing a patch for 4.6 now.

Sonam,

Please advise patch name/type whatever when you receive so I may request this as well. Thanks in advance.

Ray

Sure thing Ray. I’ll let you know when the duplicate delivery problem is fixed in 4.6.

We’ve had to install a different patch for 4.6 - FIX 3 for B2B 4.6 - to deal with null pointer exceptions thrown during document deliveries. This is quite different from the duplicate deliveries issue and seems to occur only in certain locales (I presume non-US countries). The cause was a session object not being created before being invoked by certain WmPublic services.

Hello all, we’ve had several problems with B2B 4.6/TN 4.6 recently. These problems included:
(a) 100% CPU
(b) Java out of memory errors
© Hung delivery services with deliveries stuck in PENDING state.

We think we are out of the woods with the following patches:
IS_4-6_FIX_19, IS_4-6_FIX_13, IS_4-6_FIX_9, TNS_4-6_FIX_10, TNS_4-6_FIX_7, TNS_4-6_FIX_4, IS_4-6_FIX_4, IS_4-6_FIX_3

In particular, IS patches 13 and 19 were crucial in fixing the issues mentioned above.

Hello ,

This is one of the old discussion threads. I am facing the same problem on WMTN4.6.

We are using WMTN 4.6 and still see the PENDING TASK problem.

We have the following patches
IS_4-6_SP1(this i suppose includes the fixes that solved problems in your case)
TNS_4-6_FIX_7,
TNS_4-6_FIX_30 (which supercedes-: TNS_4-6_FIX_3, TNS_4-6_FIX_8, TNS_4-6_FIX_9, TNS_4-6_FIX_13,
TNS_4-6_FIX_15, TNS_4-6_FIX_16, TNS_4-6_FIX_17, TNS_4-6_FIX_18,
TNS_4-6_FIX_23, TNS_4-6_FIX_24, TNS_4-6_FIX_26)

I have been trying to get response from the WM Support on this.
Meanwhile need input from you guys as well.
Sonam, Pls advice , since you have seen and resolved this problem.

Thanks,
sindhu

Sindhu:

> IS_4-6_SP1(this i suppose includes the fixes that solved
> problems in your case)

There’s a gotcha here… IS 4.6 SP1 does not include IS 4-6 Fix19 - one of the fixes we needed (you can see this in the README). Its not included in either IS 4.6 SP2 either - you have to install it seperately.

WM recently released TN 4.6 SP1. We will be testing the combination of:
IS 4.6 FIX 19 + IS 4.6 SP2 and TN 4.6 SP1
in a few days. If you’re testing this combination as well, could you let us know if this fixed your problem?

Sonam, we are yet to test this combination.
If you are already through with this test , Can u pls update me on the results of the said combination ?