Too many repository nodes


I’m using tamino

when I’m trying to set the index of an element to text I get the following error: Too many repository nodes.

What do I have to do to get rid of this error??


This occurs if there are many paths to your element and a recursion or an any is involved AND if you set your index for the path, that means every existing path.
Now you have to specify the path explicitly.
To achieve this, click on the “Advanced” button in the physical properties pane. Remove your index settings from the path. Add a new XPath and enter all paths to your element that are to be indexed. Use the notation /qualifiedElementName1/…/qualifiedElementNameX or …/@attributeName. You can concat two paths with ;