TN is not splitting EDIINT doc at transaction level by default

Hi All,

We are using EDIINT AS2 to receive edi 824/827 from client.
As the number of transactions in 824 may be more than 100, we opted for splitting at group level and processing the entire document once.
But, when the EDIINT doc reaches TN, it is not getting splitted automatically.
From documentation, I understand that if we do not define user specific TPA, default TPA will be selected and the document splits at transaction level.
So, I have not created any TPA, to see if the EDIINT splits at transaction level by default.

But, when TN receives EDIINT doc, it is not getting splitted. when EDIINT doc comes, default processing rule is selected and wm.EDIINT.rules:processMsg service is invoked and MDN is sent to them succesfully. The process stops here.

My requirement is, after sending back MDN, I have to process the document. I have placed processing rule on EDIEnvolope doc, assuming the doc splits. But, my processing service never gets invoked as the doc is not splitting.

can any one pls help me if I am missing something here.

Hi Venky,

Please ensure that your EDIINT config property “Submit Payload to TN” is checked.

Is the EDIINT payload (824/827 edidata) being extracted and submitted to TN? This setting should be checked on in the Solutions/EDIINT page of the ISAdmin Console.Please check it.

Also your processing rule document type should look for X12Group or X12 824 transaction set instead of X12Envelope as you are split condition is Group level not the Interchange.

HTH,
RMG

Hi…

First let me thank you for your quick response on the issue.

I have checked the config property and submit payload to TN check box is selected. Also, when EDI 824 comes to TN, it is decrypted successfully and I can see the decrypted data in TN as payload.

The only point where I got struck is, the EDI document is not splitting up and hence I could not continue with my business logic.

In the file that client sends us, ISA 05 was ZZ - mutually defined.
hence, I defined ‘mutually defined’ external ID type to my partner profile for the TN to recognise. Not sure if I have to ask the client to send in the data only duns number

Also, I found that after decryting the file, the content type of the payload in TN as text/plain.

I doubt this may be the problem and asked my client to submit the data with the content type application/edi-x12.

Please let me know If I am heading in the wrong direction

yes, content type should be “application/edi-x12”. Please work with your partner to get it fixed.
It should resolve your problem.

cheers!
-nD

Hi,

I got this fixed, and the EDIINT doc is splitting up when the client send us the data with content type “application/edi-x12”

Thank you all for your warm response.

Also, Now, I need to change the split option to group/interchange as it makes TN look messy if I go for default transaction level splitting (considering the transactions may be more than 100). For this I need to create parner specific TPA

can you please advice if I can duplicate the defailt EDIINT TPA and just change the split option keeping remaining all options as is… including the init service? or is there any better way of creating TPA with only the split option changing?

Also, will wM handle effectively handle say 1000 transactions? Cos we are told in the peak time it may touch 1000 transactions and the business dont want to test the code with 1000 transactions as it takes too much of effort

Thanks,
Venkat

Hi Venkat,

Yes, you can duplicate the default EDITPA and just change the split option. Be sure to change the agreement ID from ‘Copy of EDITPA’ to ‘EDITPA’.

I’m not sure about the 1000 transactions. That’s not a lot from a wM performance perspective (in most instances).

hello julia here… i am related to telecoms company .mcitp study.Telecom Carrier opportunities in automotive supply chain e-commerce networks As EDI wrestles with XML, should the carriers build out new “smart bearer XML VANS?” :):):slight_smile:

Hi tillmanm,

thanks for the advice. this worked.
But what I noticed is, from the same client we receive 997 and 824.
when 824 comes, the EDIINT doc is splitting at group level as needed, but 997 is still splitting at transaction level.
this is not a big concern for us, but interested to know why this behavior?
can you please help out.

Also, i am getting an error “cannot retrieve data from server” when I try to delete my old TPA’s. Any clue on how to solve this as well.

Thanks,
Venkat

Hi Venkat,

Perhaps the 997 is still using the default TPA. Please make sure the sender/receiver info is the same for both 997 and 824. You may try disabling the default TPA and processing the 997 to determine if it using that default TPA.

We have the same issue with not being able to delete the TPA’s and have not resolved that yet. We are just disabling them for now.

Hi tillmanm,

If you cant delete TPA from TN, run the service wm.tn.tpa:deleteTPA from the developer with the necessary inputs and this deletes the TPA in TN.

Deleting the TPA from Developer worked, Venky. Thanks for the info!

Hi All,

Please help me to resolve the issue i am having with EDIINT message that is a lot similar to this chain.

I am getting an EDIINT message and the user status i see is “ProcessMsg”, whereas it should be “ProcessMsg:PAYLOAD”. From what i understood is that the payloadID is not submitted to TN, but the checkbox to submit to TN is checked in the admin console.
I do not see a transaction showing up and processing in TN. The content type i am seeing is “Content-Type: Application/pkcs7-mime;name=EDIINTEDI.p7m;smime-type=enveloped-data”.

Also, i do not have any EDITPA’s set up. Do they have to be set up to receive EDIINT messages?

Thanks
Stepheny

Are you seeing content-type “Application/pkcs7-mime” for transaction palyload?..What document type are you receiving EDI or XML?

“I do not have any EDITPA’s set up. Do they have to be set up to receive EDIINT messages?” --> No it can use default TPA unless nothing defined.

HTH,
RMG

Yes, i get that content type for transaction payload. I see the EDI in the payload also. The document type i am getting is UCS 4010 875. But i do not see a transaction getting created in TN for that. It just stucks up with EDIINT. It invokes wm.EDIINT.rules:processMsg too. It does not even error, but the user status just remains as “ProcessMsg”.

For EDI, you should see content-type:“application/edi-x12” for transaction payload processing.

Did you try reload WmEDI or WmEDIINT package?

When the submit payload to TN is checked,it should automatically extract the payload and you should have UCS 4010 875 in TAnalysis.

HTH,
RMg

Rmg,

When i step through and see it is actually application/X12 only. I do not have issue with the content type. But this is something i found. This must be too technical, so it is ok if you think you should not respond.

I see that a service “wm.tn.doc:addContentPart” is failing as it is expecting a input for “storageRef” which comes from the service “wm.EDIINT.util:streamToBytesOrReservation” as “reservation” and it is coming empty. Those all are java services.

I am stepping through to find the issue. But if you have anyy idea, do let me know. I would greatly appreciate that.

Thanks

OK step thru/logs definitely can catch root cause…

Is it a Large document that you are processing?

Also check this article its relate to EDIModule6.1 though…(If not you can ignore)
http://advantage.webmethods.com/article/?id=SR-1-64798125

HTH,
RMG

Rmg,

When i look at the server logs this is what i see when the partner posts.
“XMLCoder decode invalid data type: java.io.SequenceInputStream”.

Thanks

Rmg,
there is nothing wrong with the file coming in. Someone has messed up the code and hence it is behaving Weird. But loading the package also did not work. I copied the package from production to test and it worked. Thanks for all your help.